summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-08-30 09:04:15 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-08-30 09:04:15 +0000
commit49510a7b7dbcb1d506d6534a6ee54fe8a459c9f1 (patch)
tree4c6d1f345ef987dd4252583e3375b1df4cde6629 /app-pda/coldsync/coldsync-2.2.5-r1.ebuild
parentEnable embed SAPI. (diff)
downloadhistorical-49510a7b7dbcb1d506d6534a6ee54fe8a459c9f1.tar.gz
historical-49510a7b7dbcb1d506d6534a6ee54fe8a459c9f1.tar.bz2
historical-49510a7b7dbcb1d506d6534a6ee54fe8a459c9f1.zip
moving dev-libs/coldsync to app-pda/coldsync
Diffstat (limited to 'app-pda/coldsync/coldsync-2.2.5-r1.ebuild')
-rw-r--r--app-pda/coldsync/coldsync-2.2.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..fff23c040860
--- /dev/null
+++ b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.1 2003/08/30 09:04:05 liquidx Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A command-line tool to synchronize PalmOS PDAs with Unix workstations"
+SRC_URI="http://www.coldsync.org/download/${P}.tar.gz"
+HOMEPAGE="http://www.coldsync.org/"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 sparc "
+
+src_compile() {
+ cd ${S}
+ local myconf
+ use nls || myconf="${myconf} --without-i18n"
+ use perl || myconf="${myconf} --without-perl"
+
+ patch -p1 < ${FILESDIR}/coldsync-2.2.5-gcc3.diff
+
+ econf ${myconf} || die "configuring coldsync failed"
+ make || die "couldn't make coldsync"
+}
+
+src_install() {
+ make \
+ PREFIX=${D}/usr \
+ MANDIR=${D}/usr/share/man \
+ SYSCONFDIR=${D}/etc \
+ DATADIR=${D}/usr/share \
+ INFODIR=${D}/usr/share/info \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLSITEMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLVENDORMAN3DIR=${D}/usr/share/man/man3 \
+ install || die "couldn't install coldsync"
+
+ dodoc AUTHORS Artistic ChangeLog HACKING INSTALL NEWS README TODO
+}