summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-31 05:50:44 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-31 05:50:44 +0000
commit9c6cd95c461121bfec4511e85e6cd5f3db96ad8d (patch)
tree80f2c0162bf73cee435c6aeca444443411889952 /app-pda/coldsync/coldsync-2.2.5-r1.ebuild
parentFix building with GCC 4.3+ and merge -broken-c++.diff and -gcc3.diff here. Ke... (diff)
downloadhistorical-9c6cd95c461121bfec4511e85e6cd5f3db96ad8d.tar.gz
historical-9c6cd95c461121bfec4511e85e6cd5f3db96ad8d.tar.bz2
historical-9c6cd95c461121bfec4511e85e6cd5f3db96ad8d.zip
clean up more
Package-Manager: portage-2.2.0_alpha29/cvs/Linux x86_64
Diffstat (limited to 'app-pda/coldsync/coldsync-2.2.5-r1.ebuild')
-rw-r--r--app-pda/coldsync/coldsync-2.2.5-r1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
index 8ea9becf97dc..d65e16e7bc4b 100644
--- a/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
+++ b/app-pda/coldsync/coldsync-2.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.12 2011/03/31 05:49:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/coldsync/coldsync-2.2.5-r1.ebuild,v 1.13 2011/03/31 05:50:44 ssuominen Exp $
EAPI=2
inherit eutils flag-o-matic perl-module toolchain-funcs
@@ -20,6 +20,12 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-toolchain.patch
+
+ if use perl; then
+ pushd perl/ColdSync
+ perl-module_src_prepare
+ popd
+ fi
}
src_configure() {