summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-01-21 11:50:23 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-01-21 11:50:23 +0000
commite367cf7566717195ac3fb3738c350836f748f4fd (patch)
treed5a3e9c8680d503c1de2a58be67a90106f25d9bc /app-pda/synce
parentversion bump, fixes bug #255729 (diff)
downloadhistorical-e367cf7566717195ac3fb3738c350836f748f4fd.tar.gz
historical-e367cf7566717195ac3fb3738c350836f748f4fd.tar.bz2
historical-e367cf7566717195ac3fb3738c350836f748f4fd.zip
better version handling
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-pda/synce')
-rw-r--r--app-pda/synce/ChangeLog5
-rw-r--r--app-pda/synce/synce-0.13.ebuild16
2 files changed, 14 insertions, 7 deletions
diff --git a/app-pda/synce/ChangeLog b/app-pda/synce/ChangeLog
index 13966e89ca75..d8a4de9953be 100644
--- a/app-pda/synce/ChangeLog
+++ b/app-pda/synce/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-pda/synce
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce/ChangeLog,v 1.13 2009/01/21 11:01:48 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce/ChangeLog,v 1.14 2009/01/21 11:50:23 mescalinum Exp $
+
+ 21 Jan 2009; Federico Ferri <mescalinum@gentoo.org> synce-0.13.ebuild:
+ better version handling
21 Jan 2009; Federico Ferri <mescalinum@gentoo.org> synce-0.13.ebuild:
changing synce deps from ~atom-${PV} to =atom-${PV}*
diff --git a/app-pda/synce/synce-0.13.ebuild b/app-pda/synce/synce-0.13.ebuild
index 31ce6c47c69b..ebf9d8232f09 100644
--- a/app-pda/synce/synce-0.13.ebuild
+++ b/app-pda/synce/synce-0.13.ebuild
@@ -1,29 +1,33 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/synce/synce-0.13.ebuild,v 1.2 2009/01/21 11:01:48 mescalinum Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/synce/synce-0.13.ebuild,v 1.3 2009/01/21 11:50:23 mescalinum Exp $
+
+inherit versionator
DESCRIPTION="Synchronize Windows CE devices with Linux."
HOMEPAGE="http://sourceforge.net/projects/synce/"
SRC_URI=""
+synce_PV=$(get_version_component_range 1-2)
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="gnome hal kde serial"
DEPEND=""
-RDEPEND="=app-pda/synce-sync-engine-${PV}*
+RDEPEND="=app-pda/synce-sync-engine-${synce_PV}*
hal? (
- =app-pda/synce-hal-${PV}*
+ =app-pda/synce-hal-${synce_PV}*
)
!hal? (
- =app-pda/synce-odccm-${PV}*
+ =app-pda/synce-odccm-${synce_PV}*
)
kde? (
- =app-pda/synce-kpm-${PV}*
+ =app-pda/synce-kpm-${synce_PV}*
)
gnome? (
~app-pda/synce-gvfs-0.2.1
- =app-pda/synce-trayicon-${PV}*
+ =app-pda/synce-trayicon-${synce_PV}*
)"
src_compile() {