summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-07-09 22:27:01 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-07-09 22:27:01 +0000
commitb3955c641a2461a37afc0adf932476d78c880f8a (patch)
treed4d9d9f8143bbac3c43b3a6e03435afe06eccc8b /app-sci
parentAdded msn fix. Submitted by Patrick McLean <chutzpah@videotron.ca> in #23625. (diff)
downloadhistorical-b3955c641a2461a37afc0adf932476d78c880f8a.tar.gz
historical-b3955c641a2461a37afc0adf932476d78c880f8a.tar.bz2
historical-b3955c641a2461a37afc0adf932476d78c880f8a.zip
new release candidate, updated SRC_URI
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/orsa/ChangeLog11
-rw-r--r--app-sci/orsa/Manifest5
-rw-r--r--app-sci/orsa/files/digest-orsa-0.3.0_rc31
-rw-r--r--app-sci/orsa/metadata.xml5
-rw-r--r--app-sci/orsa/orsa-0.3.0_rc3.ebuild39
5 files changed, 58 insertions, 3 deletions
diff --git a/app-sci/orsa/ChangeLog b/app-sci/orsa/ChangeLog
index f1d439912675..c97a19ac9709 100644
--- a/app-sci/orsa/ChangeLog
+++ b/app-sci/orsa/ChangeLog
@@ -1,8 +1,15 @@
# ChangeLog for app-sci/orsa
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.1 2003/03/13 18:01:48 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/ChangeLog,v 1.2 2003/07/09 22:26:59 george Exp $
-*orsa-0.3.0_rc1.ebuild (13 Mar 2003)
+*orsa-0.3.0_rc3 (09 Jul 2003)
+
+ 09 Jul 2003; George Shapovalov <george@gentoo.org> orsa-0.3.0_rc3.ebuild, metadata.xml :
+ new release candidate. Looks like download location has changed (as part
+ of sourceforge transition). See #24190.
+ Thanks to David Cozatt <yggsdrasil@hotmail.com> for submission
+
+*orsa-0.3.0_rc1 (13 Mar 2003)
13 Mar 2003; George Shapovalov <george@gentoo.org> ChangeLog, orsa-0.3.0_rc1.ebuild, files/{digest-orsa-0.3.0_rc1} :
initial release (#15726)
diff --git a/app-sci/orsa/Manifest b/app-sci/orsa/Manifest
index 4ec8957c564f..7d68524d84b1 100644
--- a/app-sci/orsa/Manifest
+++ b/app-sci/orsa/Manifest
@@ -1,3 +1,6 @@
-MD5 af24859547262dfa8753d1803ad1595e ChangeLog 494
MD5 14bd275cc9173160adaac8ae0c525c38 orsa-0.3.0_rc1.ebuild 1219
+MD5 2a114b9adabe6f79ab36eff5b4efefff orsa-0.3.0_rc3.ebuild 854
+MD5 7f0f5930f7f9921b4d285a52b374a602 ChangeLog 793
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 4ac11cc803cd2a23ab9da8490d841e7c files/digest-orsa-0.3.0_rc1 66
+MD5 9a419b528b36565c111576fcc7dfaa7c files/digest-orsa-0.3.0_rc3 66
diff --git a/app-sci/orsa/files/digest-orsa-0.3.0_rc3 b/app-sci/orsa/files/digest-orsa-0.3.0_rc3
new file mode 100644
index 000000000000..15a5a3dffd0a
--- /dev/null
+++ b/app-sci/orsa/files/digest-orsa-0.3.0_rc3
@@ -0,0 +1 @@
+MD5 8c1e8aea077fb31761b426aacaed2142 orsa-0.3.0-rc3.tar.gz 532564
diff --git a/app-sci/orsa/metadata.xml b/app-sci/orsa/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/app-sci/orsa/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>
diff --git a/app-sci/orsa/orsa-0.3.0_rc3.ebuild b/app-sci/orsa/orsa-0.3.0_rc3.ebuild
new file mode 100644
index 000000000000..49085f08878f
--- /dev/null
+++ b/app-sci/orsa/orsa-0.3.0_rc3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/orsa/orsa-0.3.0_rc3.ebuild,v 1.1 2003/07/09 22:26:59 george Exp $
+
+IUSE=""
+
+#inherit sourceforge
+inherit base
+inherit flag-o-matic
+
+Name=${P/_/-}
+S=${WORKDIR}/${Name}
+DESCRIPTION="ORSA Orbital Reconstruction Simulation Algorithym"
+SRC_URI="http://unc.dl.sourceforge.net/orsa/${Name}.tar.gz"
+HOMEPAGE="http://orsa.sourceforge.net"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ dev-libs/fftw
+ dev-libs/gsl
+ x11-libs/qt
+ sys-libs/readline"
+
+
+replace-flags k6-3 i586
+replace-flags k6-2 i586
+replace-flags k6 i586
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die
+}
+
+src_install () {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS
+}