summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2015-01-01 10:31:06 +0000
committerMikle Kolyada <zlogene@gentoo.org>2015-01-01 10:31:06 +0000
commitb1621259a7ab0a2c6693d53aae4537b8739d29e6 (patch)
tree8147a87a8dc759c5f17600c4cdd270f33ea9edc1 /app-shells/mksh/mksh-48b.ebuild
parentVersion bump for Rails 4.2. Dropped keywords tracked in bug 534186. (diff)
downloadhistorical-b1621259a7ab0a2c6693d53aae4537b8739d29e6.tar.gz
historical-b1621259a7ab0a2c6693d53aae4537b8739d29e6.tar.bz2
historical-b1621259a7ab0a2c6693d53aae4537b8739d29e6.zip
Security cleanup
Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0xC42EB5D6
Diffstat (limited to 'app-shells/mksh/mksh-48b.ebuild')
-rw-r--r--app-shells/mksh/mksh-48b.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/app-shells/mksh/mksh-48b.ebuild b/app-shells/mksh/mksh-48b.ebuild
deleted file mode 100644
index a44928e5b20b..000000000000
--- a/app-shells/mksh/mksh-48b.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mksh/mksh-48b.ebuild,v 1.4 2014/02/23 08:50:40 ago Exp $
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="MirBSD KSH Shell"
-HOMEPAGE="http://mirbsd.de/mksh"
-SRC_URI="http://www.mirbsd.org/MirOS/dist/mir/mksh/${PN}-R${PV}.tgz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-IUSE="static"
-DEPEND="static? ( dev-libs/klibc )"
-RDEPEND=""
-S="${WORKDIR}/${PN}"
-
-src_compile() {
- tc-export CC
- # we want to build static with klibc
- if use static; then unset CC; export CC="/usr/bin/klcc"; export LDSTATIC="-static"; fi
- export CPPFLAGS="${CPPFLAGS} -DMKSH_DEFAULT_PROFILEDIR=\\\"${EPREFIX}/etc\\\""
- # we can't assume lto existing/enabled, so we add a fallback
- sh Build.sh -r -c lto || sh Rebuild.sh || die
-}
-
-src_install() {
- exeinto /bin
- doexe mksh
- doman mksh.1
- dodoc dot.mkshrc
-}
-
-src_test() {
- ./test.sh || die
-}