summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-01-16 21:43:13 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-01-16 21:43:13 +0000
commit738dbe34ad0e5372e9eb0541b5a9e0d97a536c86 (patch)
tree02468844e3edd5ecf127be74a6c19c5ee8956717 /app-shells
parentInitial commit. (diff)
downloadhistorical-738dbe34ad0e5372e9eb0541b5a9e0d97a536c86.tar.gz
historical-738dbe34ad0e5372e9eb0541b5a9e0d97a536c86.tar.bz2
historical-738dbe34ad0e5372e9eb0541b5a9e0d97a536c86.zip
This release contains fixes for two important bugs that caused large
issues with running on OS X, NetBSD, and possibly other operating systems. It has i18n support, including the first translation (Swedish), a better short-circut syntax, command-specific completions for several new commands, including gpg, and a large number of minor tweaks and bugfixes. Info taken from Freshmeat release. Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/fish/ChangeLog12
-rw-r--r--app-shells/fish/Manifest4
-rw-r--r--app-shells/fish/files/digest-fish-1.20.01
-rw-r--r--app-shells/fish/fish-1.20.0.ebuild38
4 files changed, 53 insertions, 2 deletions
diff --git a/app-shells/fish/ChangeLog b/app-shells/fish/ChangeLog
index 474615ae92eb..f67fc8961f6a 100644
--- a/app-shells/fish/ChangeLog
+++ b/app-shells/fish/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-shells/fish
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.10 2006/01/03 05:54:05 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/ChangeLog,v 1.11 2006/01/16 21:43:13 spyderous Exp $
+
+*fish-1.20.0 (16 Jan 2006)
+
+ 16 Jan 2006; Donnie Berkholz <spyderous@gentoo.org>; +fish-1.20.0.ebuild:
+ This release contains fixes for two important bugs that caused large
+ issues with running on OS X, NetBSD, and possibly other operating
+ systems. It has i18n support, including the first translation
+ (Swedish), a better short-circut syntax, command-specific completions
+ for several new commands, including gpg, and a large number of minor
+ tweaks and bugfixes. Info taken from Freshmeat release.
*fish-1.19.0 (03 Jan 2006)
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index d18d8389bac4..c1d84b70f136 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,6 +1,8 @@
-MD5 db0b42ac2b57eb8c020011701af0de2d ChangeLog 2115
+MD5 ae511763c8bb058ec1c7a09baea7b5e2 ChangeLog 2624
MD5 59fc62b7cad7793b3368e699fc4b31a9 files/digest-fish-1.18.2 64
MD5 1f606fe3701c33c32b91055ff29c17f8 files/digest-fish-1.19.0 64
+MD5 f6fa176d3e3f20f84fa319242532b423 files/digest-fish-1.20.0 64
MD5 be32f656fb05d2fe0f376b678c9eef9c fish-1.18.2.ebuild 936
MD5 b14c46bef356009efed3741d2fb926d6 fish-1.19.0.ebuild 936
+MD5 4eed9ee52a6be3fa234b104cd8629550 fish-1.20.0.ebuild 936
MD5 60f93915838cb266eef644d5f73c9d19 metadata.xml 225
diff --git a/app-shells/fish/files/digest-fish-1.20.0 b/app-shells/fish/files/digest-fish-1.20.0
new file mode 100644
index 000000000000..ebca6be1a01f
--- /dev/null
+++ b/app-shells/fish/files/digest-fish-1.20.0
@@ -0,0 +1 @@
+MD5 9cfce4c862f8f8bc37e99761be289643 fish-1.20.0.tar.bz2 454506
diff --git a/app-shells/fish/fish-1.20.0.ebuild b/app-shells/fish/fish-1.20.0.ebuild
new file mode 100644
index 000000000000..29318b271163
--- /dev/null
+++ b/app-shells/fish/fish-1.20.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/fish/fish-1.20.0.ebuild,v 1.1 2006/01/16 21:43:13 spyderous Exp $
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://roo.no-ip.org/fish/"
+SRC_URI="http://roo.no-ip.org/fish/files/${PV}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND="sys-libs/ncurses
+ sys-devel/bc
+ || ( (
+ x11-libs/libSM
+ x11-libs/libXext
+ )
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen"
+
+src_compile() {
+ econf docdir=/usr/share/doc/${PF} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you want to use fish as your default shell, you need to add it"
+ einfo "to /etc/shells. This is not recommended because fish doesn't install"
+ einfo "to /bin."
+ einfo
+}