summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-10 06:35:04 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-10 06:35:04 +0000
commitce60f7d4c640213bcd5711325a15abd962851742 (patch)
tree7d5ee0661e77f25aa819171047fccc67c1cebb41 /app-shells
parentMake sure we block and not depend on split themes #260752 by Hopeless. (diff)
downloadhistorical-ce60f7d4c640213bcd5711325a15abd962851742.tar.gz
historical-ce60f7d4c640213bcd5711325a15abd962851742.tar.bz2
historical-ce60f7d4c640213bcd5711325a15abd962851742.zip
old
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-4.0.ebuild196
-rw-r--r--app-shells/bash/files/bash-4.0-associative-array-subscripts.patch232
-rw-r--r--app-shells/bash/files/bash-4.0-comsub-backslash-metacharacters.patch17
-rw-r--r--app-shells/bash/files/bash-4.0-comsub-comments.patch31
-rw-r--r--app-shells/bash/files/bash-4.0-comsub-herestring.patch22
-rw-r--r--app-shells/bash/files/bash-4.0-declare-identifier.patch31
-rw-r--r--app-shells/bash/files/bash-4.0-exit-checkjobs.patch17
-rw-r--r--app-shells/bash/files/bash-4.0-pcomplete-save-parser-state.patch12
-rw-r--r--app-shells/bash/files/bash-4.0-pipeline-reserved-word.patch12
-rw-r--r--app-shells/bash/files/bash-4.0-read-timeout-reset.patch32
-rw-r--r--app-shells/bash/files/bash-4.0-reset-parser-current-token.patch13
-rw-r--r--app-shells/bash/files/bash-4.0-save-current-token.patch32
12 files changed, 0 insertions, 647 deletions
diff --git a/app-shells/bash/bash-4.0.ebuild b/app-shells/bash/bash-4.0.ebuild
deleted file mode 100644
index 40a9692b49ce..000000000000
--- a/app-shells/bash/bash-4.0.ebuild
+++ /dev/null
@@ -1,196 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-4.0.ebuild,v 1.14 2009/03/03 22:52:11 vapier Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-# Official patchlevel
-# See ftp://ftp.cwru.edu/pub/bash/bash-3.2-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-READLINE_VER=6.0
-READLINE_PLEVEL=0 # both readline patches are also released as bash patches
-patches() {
- local opt=$1 plevel=${2:-${PLEVEL}} pn=${3:-${PN}} pv=${4:-${MY_PV}}
- [[ ${plevel} -eq 0 ]] && return 1
- eval set -- {1..${plevel}}
- set -- $(printf "${pn}${pv/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}\/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${pn} ; do
- printf "${u}/${pn}-${pv}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="The standard GNU Bourne again shell"
-HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
-SRC_URI="mirror://gnu/bash/${MY_P}.tar.gz $(patches)
- $(patches ${READLINE_PLEVEL} readline ${READLINE_VER})"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS=""
-IUSE="afs bashlogger examples +net nls plugins vanilla"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-RDEPEND="${DEPEND}
- !<sys-apps/portage-2.1.5
- !<sys-apps/paludis-0.26.0_alpha5"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- if is-flag -malign-double ; then #7332
- eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
- eerror "as it breaks LFS (struct stat64) on x86."
- die "remove -malign-double from your CFLAGS mr ricer"
- fi
-}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
- cd "${S}"
-
- # Include official patches
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- cd lib/readline
- [[ ${READLINE_PLEVEL} -gt 0 ]] && epatch $(patches -s ${READLINE_PLEVEL} readline ${READLINE_VER})
- cd ../..
-
- if ! use vanilla ; then
- epatch "${FILESDIR}"/${PN}-3.2-parallel-build.patch #189671
- epatch "${FILESDIR}"/${PN}-4.0-ldflags-for-build.patch #211947
- epatch "${FILESDIR}"/${P}-pcomplete-save-parser-state.patch
- epatch "${FILESDIR}"/${P}-comsub-backslash-metacharacters.patch
- epatch "${FILESDIR}"/${P}-save-current-token.patch
- epatch "${FILESDIR}"/${P}-exit-checkjobs.patch
- epatch "${FILESDIR}"/${P}-declare-identifier.patch
- epatch "${FILESDIR}"/${P}-reset-parser-current-token.patch
- epatch "${FILESDIR}"/${P}-pipeline-reserved-word.patch
- epatch "${FILESDIR}"/${P}-associative-array-subscripts.patch
- epatch "${FILESDIR}"/${P}-comsub-herestring.patch
- epatch "${FILESDIR}"/${P}-comsub-comments.patch
- epatch "${FILESDIR}"/${P}-read-timeout-reset.patch
- epatch "${FILESDIR}"/${PN}-4.0-negative-return.patch
- # Log bash commands to syslog #91327
- if use bashlogger ; then
- ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
- ewarn "This will log ALL output you enter into the shell, you have been warned."
- ebeep
- epause
- epatch "${FILESDIR}"/${PN}-3.1-bash-logger.patch
- fi
- fi
-}
-
-src_compile() {
- local myconf=
-
- # For descriptions of these, see config-top.h
- # bashrc/#26952 bash_logout/#90488 ssh/#24762
- append-cppflags \
- -DDEFAULT_PATH_VALUE=\'\"/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin\"\' \
- -DSTANDARD_UTILS_PATH=\'\"/bin:/usr/bin:/sbin:/usr/sbin\"\' \
- -DSYS_BASHRC=\'\"/etc/bash/bashrc\"\' \
- -DSYS_BASH_LOGOUT=\'\"/etc/bash/bash_logout\"\' \
- -DNON_INTERACTIVE_LOGIN_SHELLS \
- -DSSH_SOURCE_BASHRC
-
- # Always use the buildin readline, else if we update readline
- # bash gets borked as readline is usually not binary compadible
- # between minor versions.
- #myconf="${myconf} $(use_with !readline installed-readline)"
- myconf="${myconf} --without-installed-readline"
-
- # Don't even think about building this statically without
- # reading Bug 7714 first. If you still build it statically,
- # don't come crying to us with bugs ;).
- #use static && export LDFLAGS="${LDFLAGS} -static"
- use nls || myconf="${myconf} --disable-nls"
-
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses
- myconf="${myconf} --with-curses"
-
- use plugins && append-ldflags -Wl,-rpath,/usr/$(get_libdir)/bash
- econf \
- $(use_with afs) \
- $(use_enable net net-redirections) \
- --disable-profiling \
- --without-gnu-malloc \
- ${myconf} || die
- emake || die "make failed"
-
- if use plugins ; then
- emake -C examples/loadables all others || die
- fi
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
-
- dodir /bin
- mv "${D}"/usr/bin/bash "${D}"/bin/ || die
- dosym bash /bin/rbash
-
- insinto /etc/bash
- doins "${FILESDIR}"/{bashrc,bash_logout}
- insinto /etc/skel
- for f in bash{_logout,_profile,rc} ; do
- newins "${FILESDIR}"/dot-${f} .${f}
- done
-
- sed -i -e "s:#${USERLAND}#@::" "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
- sed -i -e '/#@/d' "${D}"/etc/skel/.bashrc "${D}"/etc/bash/bashrc
-
- if use plugins ; then
- exeinto /usr/$(get_libdir)/bash
- doexe $(echo examples/loadables/*.o | sed 's:\.o::g') || die
- fi
-
- if use examples ; then
- for d in examples/{functions,misc,scripts,scripts.noah,scripts.v2} ; do
- exeinto /usr/share/doc/${PF}/${d}
- insinto /usr/share/doc/${PF}/${d}
- for f in ${d}/* ; do
- if [[ ${f##*/} != PERMISSION ]] && [[ ${f##*/} != *README ]] ; then
- doexe ${f}
- else
- doins ${f}
- fi
- done
- done
- fi
-
- doman doc/*.1
- dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
- dosym bash.info /usr/share/info/bashref.info
-}
-
-pkg_preinst() {
- if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
- mkdir -p "${ROOT}"/etc/bash
- mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
- fi
-
- if [[ -L ${ROOT}/bin/sh ]]; then
- # rewrite the symlink to ensure that its mtime changes. having /bin/sh
- # missing even temporarily causes a fatal error with paludis.
- local target=$(readlink "${ROOT}"/bin/sh)
- ln -sf "${target}" "${ROOT}"/bin/sh
- fi
-}
-
-pkg_postinst() {
- # If /bin/sh does not exist, provide it
- if [[ ! -e ${ROOT}/bin/sh ]]; then
- ln -sf bash "${ROOT}"/bin/sh
- fi
-}
diff --git a/app-shells/bash/files/bash-4.0-associative-array-subscripts.patch b/app-shells/bash/files/bash-4.0-associative-array-subscripts.patch
deleted file mode 100644
index 6dfc7d1ad0fb..000000000000
--- a/app-shells/bash/files/bash-4.0-associative-array-subscripts.patch
+++ /dev/null
@@ -1,232 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00188.html
-
-*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
---- parse.y 2009-02-25 17:25:56.000000000 -0500
-***************
-*** 2916,2919 ****
---- 2919,2923 ----
- #define P_COMMAND 0x08 /* parsing a command, so look for comments */
- #define P_BACKQUOTE 0x10 /* parsing a backquoted command substitution */
-+ #define P_ARRAYSUB 0x20 /* parsing a [...] array subscript for assignment */
-
- /* Lexical state while parsing a grouping construct or $(...). */
-***************
-*** 3130,3133 ****
---- 3134,3139 ----
- FREE (nestret);
- }
-+ else if ((flags & P_ARRAYSUB) && (tflags & LEX_WASDOL) && (ch == '(' || ch == '{' || ch == '[')) /* ) } ] */
-+ goto parse_dollar_word;
- }
- /* Parse an old-style command substitution within double quotes as a
-***************
-*** 3146,3149 ****
---- 3152,3156 ----
- /* check for $(), $[], or ${} inside quoted string. */
- {
-+ parse_dollar_word:
- if (open == ch) /* undo previous increment */
- count--;
-***************
-*** 4249,4253 ****
- (token_index == 0 && (parser_state&PST_COMPASSIGN))))
- {
-! ttok = parse_matched_pair (cd, '[', ']', &ttoklen, 0);
- if (ttok == &matched_pair_error)
- return -1; /* Bail immediately. */
---- 4256,4260 ----
- (token_index == 0 && (parser_state&PST_COMPASSIGN))))
- {
-! ttok = parse_matched_pair (cd, '[', ']', &ttoklen, P_ARRAYSUB);
- if (ttok == &matched_pair_error)
- return -1; /* Bail immediately. */
-*** ../bash-4.0/arrayfunc.c 2009-01-04 14:32:21.000000000 -0500
---- arrayfunc.c 2009-02-25 07:58:54.000000000 -0500
-***************
-*** 605,666 ****
- }
-
-! /* This function assumes s[i] == '['; returns with s[ret] == ']' if
-! an array subscript is correctly parsed. */
-! int
-! skipsubscript (s, i)
-! const char *s;
-! int i;
-! {
-! int count, c;
-! #if defined (HANDLE_MULTIBYTE)
-! mbstate_t state, state_bak;
-! size_t slength, mblength;
-! #endif
-!
-! #if defined (HANDLE_MULTIBYTE)
-! memset (&state, '\0', sizeof (mbstate_t));
-! slength = strlen (s + i);
-! #endif
-!
-! count = 1;
-! while (count)
-! {
-! /* Advance one (possibly multibyte) character in S starting at I. */
-! #if defined (HANDLE_MULTIBYTE)
-! if (MB_CUR_MAX > 1)
-! {
-! state_bak = state;
-! mblength = mbrlen (s + i, slength, &state);
-!
-! if (MB_INVALIDCH (mblength))
-! {
-! state = state_bak;
-! i++;
-! slength--;
-! }
-! else if (MB_NULLWCH (mblength))
-! return i;
-! else
-! {
-! i += mblength;
-! slength -= mblength;
-! }
-! }
-! else
-! #endif
-! ++i;
-!
-! c = s[i];
-!
-! if (c == 0)
-! break;
-! else if (c == '[')
-! count++;
-! else if (c == ']')
-! count--;
-! }
-!
-! return i;
-! }
-
- /* This function is called with SUB pointing to just after the beginning
---- 605,609 ----
- }
-
-! /* skipsubscript moved to subst.c to use private functions. 2009/02/24. */
-
- /* This function is called with SUB pointing to just after the beginning
-*** ../bash-4.0/subst.c 2009-01-28 14:34:12.000000000 -0500
---- subst.c 2009-02-25 09:18:33.000000000 -0500
-***************
-*** 223,226 ****
---- 223,227 ----
- static char *extract_delimited_string __P((char *, int *, char *, char *, char *, int));
- static char *extract_dollar_brace_string __P((char *, int *, int, int));
-+ static int skip_matched_pair __P((const char *, int, int, int, int));
-
- static char *pos_params __P((char *, int, int, int));
-***************
-*** 1375,1378 ****
---- 1376,1480 ----
- #define CQ_RETURN(x) do { no_longjmp_on_fatal_error = 0; return (x); } while (0)
-
-+ /* This function assumes s[i] == open; returns with s[ret] == close; used to
-+ parse array subscripts. FLAGS currently unused. */
-+ static int
-+ skip_matched_pair (string, start, open, close, flags)
-+ const char *string;
-+ int start, open, close, flags;
-+ {
-+ int i, pass_next, backq, si, c, count;
-+ size_t slen;
-+ char *temp, *ss;
-+ DECLARE_MBSTATE;
-+
-+ slen = strlen (string + start) + start;
-+ no_longjmp_on_fatal_error = 1;
-+
-+ i = start + 1; /* skip over leading bracket */
-+ count = 1;
-+ pass_next = backq = 0;
-+ ss = (char *)string;
-+ while (c = string[i])
-+ {
-+ if (pass_next)
-+ {
-+ pass_next = 0;
-+ if (c == 0)
-+ CQ_RETURN(i);
-+ ADVANCE_CHAR (string, slen, i);
-+ continue;
-+ }
-+ else if (c == '\\')
-+ {
-+ pass_next = 1;
-+ i++;
-+ continue;
-+ }
-+ else if (backq)
-+ {
-+ if (c == '`')
-+ backq = 0;
-+ ADVANCE_CHAR (string, slen, i);
-+ continue;
-+ }
-+ else if (c == '`')
-+ {
-+ backq = 1;
-+ i++;
-+ continue;
-+ }
-+ else if (c == open)
-+ {
-+ count++;
-+ i++;
-+ continue;
-+ }
-+ else if (c == close)
-+ {
-+ count--;
-+ if (count == 0)
-+ break;
-+ i++;
-+ continue;
-+ }
-+ else if (c == '\'' || c == '"')
-+ {
-+ i = (c == '\'') ? skip_single_quoted (ss, slen, ++i)
-+ : skip_double_quoted (ss, slen, ++i);
-+ /* no increment, the skip functions increment past the closing quote. */
-+ }
-+ else if (c == '$' && (string[i+1] == LPAREN || string[i+1] == LBRACE))
-+ {
-+ si = i + 2;
-+ if (string[si] == '\0')
-+ CQ_RETURN(si);
-+
-+ if (string[i+1] == LPAREN)
-+ temp = extract_delimited_string (ss, &si, "$(", "(", ")", SX_NOALLOC|SX_COMMAND); /* ) */
-+ else
-+ temp = extract_dollar_brace_string (ss, &si, 0, SX_NOALLOC);
-+ i = si;
-+ if (string[i] == '\0') /* don't increment i past EOS in loop */
-+ break;
-+ i++;
-+ continue;
-+ }
-+ else
-+ ADVANCE_CHAR (string, slen, i);
-+ }
-+
-+ CQ_RETURN(i);
-+ }
-+
-+ #if defined (ARRAY_VARS)
-+ int
-+ skipsubscript (string, start)
-+ const char *string;
-+ int start;
-+ {
-+ return (skip_matched_pair (string, start, '[', ']', 0));
-+ }
-+ #endif
-+
- /* Skip characters in STRING until we find a character in DELIMS, and return
- the index of that character. START is the index into string at which we
diff --git a/app-shells/bash/files/bash-4.0-comsub-backslash-metacharacters.patch b/app-shells/bash/files/bash-4.0-comsub-backslash-metacharacters.patch
deleted file mode 100644
index e47a14369d8c..000000000000
--- a/app-shells/bash/files/bash-4.0-comsub-backslash-metacharacters.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00147.html
-
-*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
---- parse.y 2009-02-22 16:08:54.000000000 -0500
-***************
-*** 3307,3311 ****
-
- /* Meta-characters that can introduce a reserved word. Not perfect yet. */
-! if MBTEST((tflags & LEX_RESWDOK) == 0 && (tflags & LEX_CKCASE) && (tflags & LEX_INCOMMENT) == 0 && shellmeta(ch))
- {
- /* Add this character. */
---- 3307,3311 ----
-
- /* Meta-characters that can introduce a reserved word. Not perfect yet. */
-! if MBTEST((tflags & LEX_PASSNEXT) == 0 && (tflags & LEX_RESWDOK) == 0 && (tflags & LEX_CKCASE) && (tflags & LEX_INCOMMENT) == 0 && shellmeta(ch))
- {
- /* Add this character. */
diff --git a/app-shells/bash/files/bash-4.0-comsub-comments.patch b/app-shells/bash/files/bash-4.0-comsub-comments.patch
deleted file mode 100644
index 4a753d65be81..000000000000
--- a/app-shells/bash/files/bash-4.0-comsub-comments.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-03/msg00018.html
-
-*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
---- parse.y 2009-03-03 16:58:50.000000000 -0500
-***************
-*** 3172,3175 ****
---- 3179,3187 ----
- }
-
-+ /* Not exactly right yet, should handle shell metacharacters, too. If
-+ any changes are made to this test, make analogous changes to subst.c:
-+ extract_delimited_string(). */
-+ #define COMMENT_BEGIN(x) ((x) == '#' && (retind == 0 || ret[retind-1] == '\n' || shellblank (ret[retind - 1])))
-+
- /* Parse a $(...) command substitution. This is messier than I'd like, and
- reproduces a lot more of the token-reading code than I'd like. */
-***************
-*** 3365,3369 ****
- tflags &= ~LEX_RESWDOK;
- }
-! else if (shellbreak (ch) == 0)
- {
- tflags &= ~LEX_RESWDOK;
---- 3377,3383 ----
- tflags &= ~LEX_RESWDOK;
- }
-! else if MBTEST((tflags & LEX_CKCOMMENT) && COMMENT_BEGIN(ch))
-! ; /* don't turn off LEX_RESWDOK if we're starting a comment */
-! else if MBTEST(shellbreak (ch) == 0)
- {
- tflags &= ~LEX_RESWDOK;
diff --git a/app-shells/bash/files/bash-4.0-comsub-herestring.patch b/app-shells/bash/files/bash-4.0-comsub-herestring.patch
deleted file mode 100644
index d30e271c9dee..000000000000
--- a/app-shells/bash/files/bash-4.0-comsub-herestring.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00230.html
-
-*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
---- parse.y 2009-02-26 17:22:15.000000000 -0500
-***************
-*** 3395,3400 ****
- else
- shell_ungetc (peekc);
-! tflags |= LEX_HEREDELIM;
-! lex_firstind = -1;
- continue;
- }
---- 3402,3410 ----
- else
- shell_ungetc (peekc);
-! if (peekc != '<')
-! {
-! tflags |= LEX_HEREDELIM;
-! lex_firstind = -1;
-! }
- continue;
- }
diff --git a/app-shells/bash/files/bash-4.0-declare-identifier.patch b/app-shells/bash/files/bash-4.0-declare-identifier.patch
deleted file mode 100644
index e8a5b4fd73ac..000000000000
--- a/app-shells/bash/files/bash-4.0-declare-identifier.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00206.html
-
-*** ../bash-4.0/builtins/declare.def 2009-01-04 14:32:22.000000000 -0500
---- builtins/declare.def 2009-02-26 11:40:16.000000000 -0500
-***************
-*** 296,299 ****
---- 296,306 ----
- if (t = strchr (name, '[')) /* ] */
- {
-+ /* If offset != 0 we have already validated any array reference */
-+ if (offset == 0 && valid_array_reference (name) == 0)
-+ {
-+ sh_invalidid (name);
-+ assign_error++;
-+ NEXT_VARIABLE ();
-+ }
- subscript_start = t;
- *t = '\0';
-***************
-*** 485,489 ****
- /* declare -a name[[n]] or declare name[n] makes name an indexed
- array variable. */
-! else if ((making_array_special || (flags_on & att_array)) && array_p (var) == 0)
- var = convert_var_to_array (var);
- #endif /* ARRAY_VARS */
---- 492,496 ----
- /* declare -a name[[n]] or declare name[n] makes name an indexed
- array variable. */
-! else if ((making_array_special || (flags_on & att_array)) && array_p (var) == 0 && assoc_p (var) == 0)
- var = convert_var_to_array (var);
- #endif /* ARRAY_VARS */
diff --git a/app-shells/bash/files/bash-4.0-exit-checkjobs.patch b/app-shells/bash/files/bash-4.0-exit-checkjobs.patch
deleted file mode 100644
index 419a13e51cd3..000000000000
--- a/app-shells/bash/files/bash-4.0-exit-checkjobs.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00176.html
-
-*** ../bash-4.0/builtins/exit.def 2009-01-04 14:32:22.000000000 -0500
---- builtins/exit.def 2009-02-23 22:56:58.000000000 -0500
-***************
-*** 114,118 ****
- if (jobs[i] && STOPPED (i))
- stopmsg = JSTOPPED;
-! else if (check_jobs_at_exit && stopmsg == 0 && RUNNING (i))
- stopmsg = JRUNNING;
-
---- 114,118 ----
- if (jobs[i] && STOPPED (i))
- stopmsg = JSTOPPED;
-! else if (check_jobs_at_exit && stopmsg == 0 && jobs[i] && RUNNING (i))
- stopmsg = JRUNNING;
-
diff --git a/app-shells/bash/files/bash-4.0-pcomplete-save-parser-state.patch b/app-shells/bash/files/bash-4.0-pcomplete-save-parser-state.patch
deleted file mode 100644
index 71b6e9632025..000000000000
--- a/app-shells/bash/files/bash-4.0-pcomplete-save-parser-state.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00142.html
-
-*** ../bash-4.0/pcomplete.c 2009-02-01 17:12:31.000000000 -0500
---- pcomplete.c 2009-02-22 17:08:25.000000000 -0500
-***************
-*** 1033,1036 ****
---- 1033,1037 ----
-
- pps = &ps;
-+ save_parser_state (pps);
- begin_unwind_frame ("gen-shell-function-matches");
- add_unwind_protect (restore_parser_state, (char *)pps);
diff --git a/app-shells/bash/files/bash-4.0-pipeline-reserved-word.patch b/app-shells/bash/files/bash-4.0-pipeline-reserved-word.patch
deleted file mode 100644
index 3f9da0e17a89..000000000000
--- a/app-shells/bash/files/bash-4.0-pipeline-reserved-word.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00202.html
-
-*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
---- parse.y 2009-02-25 17:25:56.000000000 -0500
-***************
-*** 4450,4453 ****
---- 4457,4461 ----
- case AND_AND:
- case BANG:
-+ case BAR_AND:
- case DO:
- case DONE:
diff --git a/app-shells/bash/files/bash-4.0-read-timeout-reset.patch b/app-shells/bash/files/bash-4.0-read-timeout-reset.patch
deleted file mode 100644
index 7f3def339277..000000000000
--- a/app-shells/bash/files/bash-4.0-read-timeout-reset.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00255.html
-http://lists.gnu.org/archive/html/bug-bash/2009-03/msg00008.html
-
-*** ../bash-4.0/builtins/read.def 2009-01-15 23:11:21.000000000 -0500
---- builtins/read.def 2009-03-02 10:15:39.000000000 -0500
-***************
-*** 370,381 ****
- if (code)
- {
-! #if 0
- run_unwind_frame ("read_builtin");
-- return (EXECUTION_FAILURE);
-- #else
- input_string[i] = '\0'; /* make sure it's terminated */
-! retval = 128+SIGALRM;;
- goto assign_vars;
-- #endif
- }
- old_alrm = set_signal_handler (SIGALRM, sigalrm);
---- 370,381 ----
- if (code)
- {
-! /* Tricky. The top of the unwind-protect stack is the free of
-! input_string. We want to run all the rest and use input_string,
-! so we have to remove it from the stack. */
-! remove_unwind_protect ();
- run_unwind_frame ("read_builtin");
- input_string[i] = '\0'; /* make sure it's terminated */
-! retval = 128+SIGALRM;
- goto assign_vars;
- }
- old_alrm = set_signal_handler (SIGALRM, sigalrm);
diff --git a/app-shells/bash/files/bash-4.0-reset-parser-current-token.patch b/app-shells/bash/files/bash-4.0-reset-parser-current-token.patch
deleted file mode 100644
index 4483953a2191..000000000000
--- a/app-shells/bash/files/bash-4.0-reset-parser-current-token.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00219.html
-
-*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
---- parse.y 2009-02-25 15:58:25.000000000 -0500
-***************
-*** 2669,2672 ****
---- 2671,2675 ----
- word_desc_to_read = (WORD_DESC *)NULL;
-
-+ current_token = '\n'; /* XXX */
- last_read_token = '\n';
- token_to_read = '\n';
-
diff --git a/app-shells/bash/files/bash-4.0-save-current-token.patch b/app-shells/bash/files/bash-4.0-save-current-token.patch
deleted file mode 100644
index 506e56858ea0..000000000000
--- a/app-shells/bash/files/bash-4.0-save-current-token.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-http://lists.gnu.org/archive/html/bug-bash/2009-02/msg00177.html
-
-*** ../bash-4.0/parse.y 2009-01-08 08:29:12.000000000 -0500
---- parse.y 2009-02-23 22:40:55.000000000 -0500
-***************
-*** 1616,1623 ****
- int *ret;
-
-! ret = (int *)xmalloc (3 * sizeof (int));
- ret[0] = last_read_token;
- ret[1] = token_before_that;
- ret[2] = two_tokens_ago;
- return ret;
- }
---- 1616,1624 ----
- int *ret;
-
-! ret = (int *)xmalloc (4 * sizeof (int));
- ret[0] = last_read_token;
- ret[1] = token_before_that;
- ret[2] = two_tokens_ago;
-+ ret[3] = current_token;
- return ret;
- }
-***************
-*** 1632,1635 ****
---- 1633,1637 ----
- token_before_that = ts[1];
- two_tokens_ago = ts[2];
-+ current_token = ts[3];
- }
-