summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCalum Selkirk <cselkirk@gentoo.org>2002-09-09 23:29:19 +0000
committerCalum Selkirk <cselkirk@gentoo.org>2002-09-09 23:29:19 +0000
commitd6ef78cd48b7ccfde1df24cedc293d5866098e77 (patch)
treefb372d95e5475816c3b7dcb31b0cbb2b75e496b1 /app-text/aspell
parentdep fix, lintool cleanup (diff)
downloadhistorical-d6ef78cd48b7ccfde1df24cedc293d5866098e77.tar.gz
historical-d6ef78cd48b7ccfde1df24cedc293d5866098e77.tar.bz2
historical-d6ef78cd48b7ccfde1df24cedc293d5866098e77.zip
Added a if ARCH = ppc and set CXXFLAGS to be less aggressive (it segfaults on ppc with higher opts).
Diffstat (limited to 'app-text/aspell')
-rw-r--r--app-text/aspell/ChangeLog7
-rw-r--r--app-text/aspell/aspell-0.50.1.ebuild11
2 files changed, 16 insertions, 2 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index ab1792017a7a..01a7d0cfbe9b 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-text/aspell
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.12 2002/09/03 10:48:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.13 2002/09/09 23:29:19 cselkirk Exp $
*aspell-0.50.1 (03 Sep 2002)
+ 10 Sep 2002; Calum Selkirk <cselkirk@gentoo.org> aspell-0.50.1.ebuild :
+
+ Added a if ARCH = ppc and set CXXFLAGS to be less aggressive (it segfaults
+ on ppc with higher opts).
+
03 Sep 2002; Seemant Kulleen <seemant@gentoo.org> aspell-0.50.1.ebuild
files/digest-aspell-0.50.1 :
diff --git a/app-text/aspell/aspell-0.50.1.ebuild b/app-text/aspell/aspell-0.50.1.ebuild
index 29ae180d419c..6839e38d20c4 100644
--- a/app-text/aspell/aspell-0.50.1.ebuild
+++ b/app-text/aspell/aspell-0.50.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.1.ebuild,v 1.1 2002/09/03 10:48:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.50.1.ebuild,v 1.2 2002/09/09 23:29:19 cselkirk Exp $
inherit libtool
@@ -23,6 +23,15 @@ KEYWORDS="x86 ppc sparc sparc64"
#CXXFLAGS="-O2"
#CFLAGS=${CXXFLAGS}
+# humm .. why are they comented? cselkirk
+
+pkg_setup() {
+ if [ ${ARCH} = "ppc" ] ; then
+ CXXFLAGS="-O2 -fsigned-char"
+ CFLAGS=${CXXFLAGS}
+ fi
+}
+
src_compile() {
elibtoolize