summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-08 13:09:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-08 13:09:49 +0000
commit2626ede8cc3da550720970493dbb261212dc307d (patch)
tree589959286b5816c72680aa4e8499a277cf21507a /app-text/crf++/crf++-0.53.ebuild
parentBump (diff)
downloadhistorical-2626ede8cc3da550720970493dbb261212dc307d.tar.gz
historical-2626ede8cc3da550720970493dbb261212dc307d.tar.bz2
historical-2626ede8cc3da550720970493dbb261212dc307d.zip
Bump
Package-Manager: portage-2.2_rc49/cvs/Linux x86_64
Diffstat (limited to 'app-text/crf++/crf++-0.53.ebuild')
-rw-r--r--app-text/crf++/crf++-0.53.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-text/crf++/crf++-0.53.ebuild b/app-text/crf++/crf++-0.53.ebuild
new file mode 100644
index 000000000000..92ec69b68911
--- /dev/null
+++ b/app-text/crf++/crf++-0.53.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/crf++/crf++-0.53.ebuild,v 1.1 2009/11/08 13:09:49 patrick Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools eutils
+
+MY_P="${P/crf/CRF}"
+DESCRIPTION="Yet Another CRF toolkit for segmenting/labelling sequential data"
+HOMEPAGE="http://crfpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/crfpp/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+ eautoreconf
+}
+
+src_test() {
+ for task in example/* ; do
+ (
+ cd "${task}"
+ ./exec.sh || die "failed test in ${task}"
+ )
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS README
+ dohtml doc/*
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}