summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-07-14 07:26:08 +0000
committerDan Armak <danarmak@gentoo.org>2001-07-14 07:26:08 +0000
commit59d0c50cc38ec3cac8456b6f895a68dd98f80e6c (patch)
tree1381deb19bd7e07d337cf78ae3e1c9bac21470f3 /app-text/gv
parentAdded optimization settings for k6 (as distinct from Pentium) and for i386 (a... (diff)
downloadhistorical-59d0c50cc38ec3cac8456b6f895a68dd98f80e6c.tar.gz
historical-59d0c50cc38ec3cac8456b6f895a68dd98f80e6c.tar.bz2
historical-59d0c50cc38ec3cac8456b6f895a68dd98f80e6c.zip
gv is a ghostscript frontend used by lyx etc. We should have had this long ago.
Diffstat (limited to 'app-text/gv')
-rw-r--r--app-text/gv/files/digest-gv-3.5.81
-rw-r--r--app-text/gv/files/gv-3.5.8-gentoo.diff17
-rw-r--r--app-text/gv/gv-3.5.8.ebuild48
3 files changed, 66 insertions, 0 deletions
diff --git a/app-text/gv/files/digest-gv-3.5.8 b/app-text/gv/files/digest-gv-3.5.8
new file mode 100644
index 000000000000..38f5c50f72fa
--- /dev/null
+++ b/app-text/gv/files/digest-gv-3.5.8
@@ -0,0 +1 @@
+MD5 8f2f0bd97395d6cea52926ddee736da8 gv-3.5.8.tar.gz
diff --git a/app-text/gv/files/gv-3.5.8-gentoo.diff b/app-text/gv/files/gv-3.5.8-gentoo.diff
new file mode 100644
index 000000000000..f9e6a1706251
--- /dev/null
+++ b/app-text/gv/files/gv-3.5.8-gentoo.diff
@@ -0,0 +1,17 @@
+--- config.Unix.orig Sat Jun 7 01:00:00 1997
++++ config.Unix Wed Jul 11 10:46:06 2001
+@@ -32,10 +32,10 @@
+ XCOMM --------------------------------------------------------------------
+ XCOMM Destination directories.
+ XCOMM --------------------------------------------------------------------
+- GV_BINDIR = /usr/local/bin/
+- GV_DOCDIR = /usr/local/doc/gv/
+- GV_LIBDIR = /usr/local/lib/gv/
+- GV_MANDIR = /usr/local/man/man1/
++ GV_BINDIR = /usr/bin/
++ GV_DOCDIR = /usr/doc/gv/
++ GV_LIBDIR = /usr/lib/gv/
++ GV_MANDIR = /usr/man/man1/
+
+ XCOMM --------------------------------------------------------------------
+ XCOMM --- The name of the Xaw3d library.
diff --git a/app-text/gv/gv-3.5.8.ebuild b/app-text/gv/gv-3.5.8.ebuild
new file mode 100644
index 000000000000..aba016868efc
--- /dev/null
+++ b/app-text/gv/gv-3.5.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <ermak@netvision.net.il>
+# /home/cvsroot/gentoo-x86/skel.build,v 1.3 2001/07/05 02:43:36 drobbins Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="gv is a standard ghostscript frontend used e.g. by LyX"
+
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/${P}.tar.gz"
+HOMEPAGE="http://wwwthep.physik.uni-mainz.de/~plass/gv/"
+
+# There's probably more, but ghostscript also depends on it,
+# so I can't identify it
+DEPEND="virtual/x11 x11-libs/Xaw3d app-text/ghostscript"
+
+src_unpack() {
+
+ # need to check if this can be done automatically
+
+ # The -gentoo patch is std: installation into /usr
+ # instead of /usr/local
+ unpack ${P}.tar.gz
+ cd ${S}
+ patch -p0 <${FILESDIR}/${P}-gentoo.diff
+
+}
+
+src_compile() {
+
+ cd ${S}
+
+ try xmkmf
+ try emake Makefiles
+ try emake
+
+}
+
+src_install () {
+
+ # BTW, how about using emake install?
+
+ try make DESTDIR=${D} install
+ try make DESTDIR=${D} install.man
+ try make DESTDIR=${D} install.doc
+
+}
+