summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-09-16 09:43:47 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-09-16 09:43:47 +0000
commit3ffc9c023215835f4aad1cb570fd9a9bde2aaa6f (patch)
tree53cb2a31e20daaa3f04c763e9c2174b8d6bf6b83 /app-text/htmlinc/htmlinc-1.0_beta1.ebuild
parentfixed typo (diff)
downloadhistorical-3ffc9c023215835f4aad1cb570fd9a9bde2aaa6f.tar.gz
historical-3ffc9c023215835f4aad1cb570fd9a9bde2aaa6f.tar.bz2
historical-3ffc9c023215835f4aad1cb570fd9a9bde2aaa6f.zip
resolves bug 7794 for gcc3.2 compat
Diffstat (limited to 'app-text/htmlinc/htmlinc-1.0_beta1.ebuild')
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
index b28e81f95c1a..98b53835cb2b 100644
--- a/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
+++ b/app-text/htmlinc/htmlinc-1.0_beta1.ebuild
@@ -1,16 +1,22 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/htmlinc-1.0_beta1.ebuild,v 1.3 2002/08/16 02:42:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/htmlinc/htmlinc-1.0_beta1.ebuild,v 1.4 2002/09/16 09:43:47 mkennedy Exp $
DESCRIPTION="HTML Include System by Ulli Meybohm"
HOMEPAGE="http://www.meybohm.de/"
KEYWORDS="x86 sparc sparc64"
SLOT="0"
-LICENSE="GPL"
-DEPEND=""
-SRC_URI="http://meybohm.de/files/htmlinc.tar.gz"
+LICENSE="GPL-2"
+DEPEND="virtual/glibc"
+RDEPEND=${DEPEND}
+SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
S=${WORKDIR}/htmlinc
+src_unpack() {
+ unpack ${PN}.tar.gz
+ patch -p0 < ${FILESDIR}/htmlinc-gcc3-gentoo.patch
+}
+
src_compile() {
emake CFLAGS="${CXXFLAGS} -Wall" || die
}