summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-12-27 13:32:24 +0000
committerTom William Payne <twp@gentoo.org>2003-12-27 13:32:24 +0000
commit4c917121e6a8e01c115def031735703309cbb8b5 (patch)
tree26ff714f14bbc94e65b385bd92193a20ecdef575 /app-text/man2html/man2html-1.5l-r1.ebuild
parentBug # 36533 (diff)
downloadhistorical-4c917121e6a8e01c115def031735703309cbb8b5.tar.gz
historical-4c917121e6a8e01c115def031735703309cbb8b5.tar.bz2
historical-4c917121e6a8e01c115def031735703309cbb8b5.zip
Bug # 36533
Diffstat (limited to 'app-text/man2html/man2html-1.5l-r1.ebuild')
-rw-r--r--app-text/man2html/man2html-1.5l-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/app-text/man2html/man2html-1.5l-r1.ebuild b/app-text/man2html/man2html-1.5l-r1.ebuild
new file mode 100644
index 000000000000..98d72d0fe75e
--- /dev/null
+++ b/app-text/man2html/man2html-1.5l-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/man2html/man2html-1.5l-r1.ebuild,v 1.1 2003/12/27 13:32:15 twp Exp $
+
+inherit eutils webapp-apache
+webapp-detect || NO_HTTPD=1
+
+DESCRIPTION="Convert manual pages to HTML"
+HOMEPAGE="http://freshmeat.net/projects/man/"
+SRC_URI="mirror://kernel/linux/utils/man/man-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha arm hppa mips sparc x86"
+
+DEPEND="app-misc/glimpse
+ sys-apps/gawk
+ sys-apps/man"
+
+S=${WORKDIR}/man-${PV}
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_HTTPD}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/mansearch-gentoo.patch
+ epatch ${FILESDIR}/manwhatis-gentoo.patch
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/htdocs/:${HTTPD_ROOT}:g"
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/cgi-bin/:${HTTPD_CGIBIN}:g"
+ find man2html -type f | xargs sed -i -e "s:/home/httpd/cgi-aux/:${HTTPD_CGIBIN/bin/aux}:g"
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp-mkdirs
+
+ cd man2html
+ exeinto ${HTTPD_CGIBIN}/man
+ doexe scripts/cgi-bin/man/*
+ insinto ${HTTPD_CGIBIN/bin/aux}/man
+ doins scripts/cgi-aux/man/*
+ insinto /var/man2html
+ newins glimpse_filters .glimpse_filters
+ fperms 1777 /var/man2html
+ exeinto /etc/cron.daily
+ doexe ${FILESDIR}/man2html.cron
+}
+
+pkg_postinst() {
+ einfo Run
+ einfo "\tebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+ einfo to complete installation.
+}
+
+pkg_config() {
+ einfo Running makewhatis
+ /usr/sbin/makewhatis
+ eend $?
+ einfo Running glimpseindex
+ /usr/bin/glimpseindex -z -H /var/man2html `man -w | tr : ' '`
+ eend $?
+ chmod 644 /var/man2html/.glimpse*
+ einfo Manual pages are available at http://localhost/cgi-bin/man/man2html
+}