summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2005-06-04 09:41:29 +0000
committerAkinori Hattori <hattya@gentoo.org>2005-06-04 09:41:29 +0000
commitdb1d01689ca08ecf1cc6c822d7554a61ba69d1d3 (patch)
tree81bf1db2d64559e88ce15de62d74325e482e4950 /app-text/mecab
parentVersion bump. (diff)
downloadhistorical-db1d01689ca08ecf1cc6c822d7554a61ba69d1d3.tar.gz
historical-db1d01689ca08ecf1cc6c822d7554a61ba69d1d3.tar.bz2
historical-db1d01689ca08ecf1cc6c822d7554a61ba69d1d3.zip
don't pass --with-charset if the unicode use flag is not set.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/ChangeLog5
-rw-r--r--app-text/mecab/Manifest14
-rw-r--r--app-text/mecab/mecab-0.81.ebuild8
3 files changed, 12 insertions, 15 deletions
diff --git a/app-text/mecab/ChangeLog b/app-text/mecab/ChangeLog
index 45645b351948..3349921e4d11 100644
--- a/app-text/mecab/ChangeLog
+++ b/app-text/mecab/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/mecab
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.16 2005/05/23 15:17:45 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.17 2005/06/04 09:41:29 hattya Exp $
+
+ 04 Jun 2005; Akinori Hattori <hattya@gentoo.org> mecab-0.81.ebuild:
+ don't pass --with-charset if the unicode use flag is not set.
23 May 2005; Gustavo Zacarias <gustavoz@gentoo.org> mecab-0.80.ebuild:
Stable on sparc
diff --git a/app-text/mecab/Manifest b/app-text/mecab/Manifest
index b32316de7151..e151e9bcc6e7 100644
--- a/app-text/mecab/Manifest
+++ b/app-text/mecab/Manifest
@@ -1,20 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 ec5bd4a9ec05211251d294431cbdde70 ChangeLog 1846
+MD5 ae20ba4590115ec28c99edd729c48e50 ChangeLog 1979
MD5 4791b77f237eb329b280249cc831b031 mecab-0.78.ebuild 820
MD5 995b5d3103496377cc3aac716a219102 mecab-0.79.ebuild 851
MD5 c3f5bb911c921ca595309d2598685a43 mecab-0.80.ebuild 948
+MD5 d03d3945c8438068ce3facf3a43dcc5f mecab-0.81.ebuild 1062
MD5 e92a48548554c80cf90e18df17ff6a82 metadata.xml 156
-MD5 13c8d130138e81ec87862b2ebc34fd6f mecab-0.81.ebuild 1013
MD5 89d2c5718559030b51532b37db3d6baf files/digest-mecab-0.78 127
MD5 d1028488de24a640c56a9eda48124838 files/digest-mecab-0.79 127
MD5 436949af36c7d36e3aea462cf05fdef3 files/digest-mecab-0.80 127
MD5 4414b5d15d244c3c5d63dff3d3c1ffc8 files/digest-mecab-0.81 189
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1-ecc0.1.6 (GNU/Linux)
-
-iD8DBQFCkfQlKRy60XGEcJIRAgvmAKCqLFy4I43dSWwZ0kPhWL2eSfeOFwCeOkmv
-whdj+5QkShC7RPSI/7FSAnY=
-=RM9C
------END PGP SIGNATURE-----
diff --git a/app-text/mecab/mecab-0.81.ebuild b/app-text/mecab/mecab-0.81.ebuild
index 2a6117a55ed7..9aecf7a72f5f 100644
--- a/app-text/mecab/mecab-0.81.ebuild
+++ b/app-text/mecab/mecab-0.81.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.81.ebuild,v 1.1 2005/05/22 15:50:53 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.81.ebuild,v 1.2 2005/06/04 09:41:29 hattya Exp $
inherit eutils
@@ -29,7 +29,11 @@ src_unpack() {
}
src_compile() {
- econf $(use_with unicode charset utf8) || die
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
emake || die
}