summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-24 17:24:06 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-24 17:24:06 +0000
commit0d2e188d347e05a5aa8b529d14f2f1d78b1faa9e (patch)
tree8233af445ca113c000bb5aa8c2936b2b112711bc /app-text/poppler/files
parentStable on alpha, bug #298204 (diff)
downloadhistorical-0d2e188d347e05a5aa8b529d14f2f1d78b1faa9e.tar.gz
historical-0d2e188d347e05a5aa8b529d14f2f1d78b1faa9e.tar.bz2
historical-0d2e188d347e05a5aa8b529d14f2f1d78b1faa9e.zip
Add proper patch instead of workaround for missing headers installation. Thanks to Maciej Mrozowski.
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'app-text/poppler/files')
-rw-r--r--app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch b/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch
new file mode 100644
index 000000000000..9eafd877b819
--- /dev/null
+++ b/app-text/poppler/files/poppler-0.12.3-fix-headers-installation.patch
@@ -0,0 +1,52 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0cd32df..070be33 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -363,6 +363,11 @@ if(ENABLE_XPDF_HEADERS)
+ goo/FixedPoint.h
+ goo/gstrtod.h
+ DESTINATION include/poppler/goo)
++ if(PNG_FOUND)
++ install(FILES
++ goo/PNGWriter.h
++ DESTINATION include/poppler/goo)
++ endif(PNG_FOUND)
+ install(FILES
+ fofi/FoFiBase.h
+ fofi/FoFiEncodings.h
+@@ -374,6 +379,9 @@ if(ENABLE_XPDF_HEADERS)
+ install(FILES
+ poppler/JPEG2000Stream.h
+ DESTINATION include/poppler)
++ install(FILES
++ poppler/goo/JpegWriter.h
++ DESTINATION include/poppler/goo)
+ else(LIBOPENJPEG_FOUND)
+ install(FILES
+ poppler/JPXStream.h
+diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
+index 6ed9523..9f5d0e7 100644
+--- a/glib/CMakeLists.txt
++++ b/glib/CMakeLists.txt
+@@ -30,6 +30,7 @@ set(poppler_glib_public_headers
+ poppler-attachment.h
+ poppler-form-field.h
+ poppler-annot.h
++ poppler-layer.h
+ poppler.h
+ )
+
+diff --git a/qt4/src/Makefile.am b/qt4/src/Makefile.am
+index 7e982e7..10ac221 100644
+--- a/qt4/src/Makefile.am
++++ b/qt4/src/Makefile.am
+@@ -16,8 +16,7 @@ poppler_include_HEADERS = \
+ poppler-form.h \
+ poppler-optcontent.h \
+ poppler-export.h \
+- poppler-page-transition.h \
+- poppler-page-transition-private.h
++ poppler-page-transition.h
+
+ lib_LTLIBRARIES = libpoppler-qt4.la
+