summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Allanos <dju@gentoo.org>2006-02-07 00:13:04 +0000
committerJulien Allanos <dju@gentoo.org>2006-02-07 00:13:04 +0000
commit147bcc1b87c18e765019c46883dcd4f477be515a (patch)
tree1044b0d895c77400c6ffe195f2f8d3cb3e97c5cc /app-text/silvercity/silvercity-0.9.6-r1.ebuild
parentMark 1.2.4.1-r1 ~ia64 (diff)
downloadhistorical-147bcc1b87c18e765019c46883dcd4f477be515a.tar.gz
historical-147bcc1b87c18e765019c46883dcd4f477be515a.tar.bz2
historical-147bcc1b87c18e765019c46883dcd4f477be515a.zip
Fix python bindings in 0.9.6, closes bug #121873.
Package-Manager: portage-2.0.54
Diffstat (limited to 'app-text/silvercity/silvercity-0.9.6-r1.ebuild')
-rw-r--r--app-text/silvercity/silvercity-0.9.6-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/silvercity/silvercity-0.9.6-r1.ebuild b/app-text/silvercity/silvercity-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..8d1cfd43de20
--- /dev/null
+++ b/app-text/silvercity/silvercity-0.9.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/silvercity-0.9.6-r1.ebuild,v 1.1 2006/02/07 00:13:04 dju Exp $
+
+inherit distutils eutils python
+
+DESCRIPTION="A lexical analyser for many languages."
+HOMEPAGE="http://silvercity.sourceforge.net/"
+
+MY_P=${P/silvercity/SilverCity}
+SRC_URI="mirror://sourceforge/silvercity/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-api-fix.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ # fix permissions
+ python_version
+ chmod 644 ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/SilverCity/default.css
+
+ # fix CR/LF issue
+ find ${D}/usr/bin -iname "*.py" -exec sed -e 's/\r$//' -i \{\} \;
+
+ # fix path
+ dosed -i 's|#!/usr/home/sweetapp/bin/python|#!/usr/bin/env python|' \
+ /usr/bin/cgi-styler-form.py || die "dosed failed"
+}