summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-05 03:32:47 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-05 03:32:47 +0000
commit6b54a5bd0322faf7247567f744c8ac62fc41fbae (patch)
tree9e13e11c0aeec4e2ecf7f4f9b923c913e254409d /app-vim/dirdiff/dirdiff-1.1.4.ebuild
parentMinor grammar fix. (diff)
downloadhistorical-6b54a5bd0322faf7247567f744c8ac62fc41fbae.tar.gz
historical-6b54a5bd0322faf7247567f744c8ac62fc41fbae.tar.bz2
historical-6b54a5bd0322faf7247567f744c8ac62fc41fbae.zip
Initial import.
Package-Manager: portage-2.2.0_alpha51/cvs/Linux x86_64
Diffstat (limited to 'app-vim/dirdiff/dirdiff-1.1.4.ebuild')
-rw-r--r--app-vim/dirdiff/dirdiff-1.1.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-vim/dirdiff/dirdiff-1.1.4.ebuild b/app-vim/dirdiff/dirdiff-1.1.4.ebuild
new file mode 100644
index 000000000000..0ebcaa0060e9
--- /dev/null
+++ b/app-vim/dirdiff/dirdiff-1.1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/dirdiff/dirdiff-1.1.4.ebuild,v 1.1 2011/09/05 03:32:47 radhermit Exp $
+
+EAPI="4"
+
+inherit vim-plugin
+
+MY_PN="DirDiff.vim"
+DESCRIPTION="vim plugin: diff and merge two directories recursively"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=102"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="DirDiff.txt"
+
+RDEPEND="sys-apps/diffutils"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '0,/" -\*- vim -\*-$/d' -e '/" 0.7 Initial Release$/,9999d' -e 's/^" \?//' \
+ -e 's/\(FILE: \)".\+\.vim"/\1*DirDiff.txt*/' \
+ plugin/DirDiff.vim \
+ > doc/DirDiff.txt
+
+ rm -f README
+}