summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2007-02-27 12:27:14 +0000
committerGeorge Shapovalov <george@gentoo.org>2007-02-27 12:27:14 +0000
commitc2cd9e79998e43051d2972eebe6199b3bd51f6f9 (patch)
tree7658a3b71bc340c0a293ea0e71538229bfbc77cb /dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild
parentdepend on baselibs-10.2 because giflib if provided there; bug 168501 (diff)
downloadhistorical-c2cd9e79998e43051d2972eebe6199b3bd51f6f9.tar.gz
historical-c2cd9e79998e43051d2972eebe6199b3bd51f6f9.tar.bz2
historical-c2cd9e79998e43051d2972eebe6199b3bd51f6f9.zip
backported gnatmake related fix from 4.1.2
Package-Manager: portage-2.1.2-r12
Diffstat (limited to 'dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild')
-rw-r--r--dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild41
1 files changed, 25 insertions, 16 deletions
diff --git a/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild b/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild
index 7d3e9837558c..7480e47bb593 100644
--- a/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild
+++ b/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild,v 1.3 2007/01/25 23:41:35 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/asis-gcc/asis-gcc-3.4.6.ebuild,v 1.4 2007/02/27 12:27:14 george Exp $
inherit eutils flag-o-matic gnatbuild
@@ -34,6 +34,12 @@ QA_EXECSTACK="usr/lib/gnat-gcc/*/${SLOT}/adalib/libasis-${SLOT}.so
# it may be even better to force plain -O2 -pipe -ftracer here
replace-flags -O3 -O2
+# we need to adjust some vars defined in gnatbuild.eclass so that they use
+# gnat-gcc instead of asis
+My_LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
+My_BINPATH=${BINPATH/${PN}/${Gnat_Name}}
+My_DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
+
pkg_setup() {
currGnat=$(eselect --no-color gnat show | grep "gnat-" | awk '{ print $1 }')
@@ -48,6 +54,15 @@ pkg_setup() {
echo
die
fi
+ if [[ -e ${My_LIBPATH}/adalib/libasis.a ]] ; then
+ echo
+ ewarn "gnatmake of gnat-gcc unfortunately has problems forcind the build"
+ ewarn "if the package is already installed."
+ eerror "Please unmerge asis-gcc first and then resume the merge:"
+ eerror "emerge --unmerge asis-gcc && emerge asis-gcc"
+ echo
+ die
+ fi
}
src_unpack() {
@@ -93,41 +108,35 @@ src_compile() {
src_install () {
- # we need to adjust some vars defined in gnatbuild.eclass so that they use
- # gnat-gcc instead of asis
- LIBPATH=${LIBPATH/${PN}/${Gnat_Name}}
- BINPATH=${BINPATH/${PN}/${Gnat_Name}}
- DATAPATH=${DATAPATH/${PN}/${Gnat_Name}}
-
# install the lib
- dodir ${LIBPATH}/adalib
+ dodir ${My_LIBPATH}/adalib
chmod 0755 lib_dyn/libasis.so
- cp lib_dyn/libasis.so ${D}${LIBPATH}/adalib/libasis-${SLOT}.so
- insinto ${LIBPATH}/adalib
+ cp lib_dyn/libasis.so ${D}${My_LIBPATH}/adalib/libasis-${SLOT}.so
+ insinto ${My_LIBPATH}/adalib
doins obj/*.ali
doins lib/libasis.a
# make appropriate symlinks
- pushd ${D}${LIBPATH}/adalib
+ pushd ${D}${My_LIBPATH}/adalib
ln -s libasis-${SLOT}.so libasis.so
popd
# sources
- insinto ${LIBPATH}/adainclude
+ insinto ${My_LIBPATH}/adainclude
doins gnat/*.ad[sb]
doins asis/*.ad[sb]
# tools
- mkdir -p ${D}${BINPATH}
+ mkdir -p ${D}${My_BINPATH}
for fn in tools/{adabrowse,asistant,gnatelim,gnatstub}; do
- cp ${fn}/${fn:6} ${D}${BINPATH}
+ cp ${fn}/${fn:6} ${D}${My_BINPATH}
done
- cp tools/semtools/ada{dep,subst} ${D}${BINPATH}
+ cp tools/semtools/ada{dep,subst} ${D}${My_BINPATH}
if use doc; then
# docs and examples
dodoc documentation/*.{txt,ps}
dohtml documentation/*.html
# info's should go into gnat-gpl dirs
- insinto ${DATAPATH}/info/
+ insinto ${My_DATAPATH}/info/
doins documentation/*.info
fi