summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-05-08 13:59:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-05-08 13:59:38 +0000
commit0870dcee4101a4b0671890953b5af27083cc5bdb (patch)
tree6d2adbbe05642910829f062ae910387733957335 /dev-cpp/gtksourceviewmm/gtksourceviewmm-3.0.0.ebuild
parentAdd support for systemd, bug #366177. (diff)
downloadhistorical-0870dcee4101a4b0671890953b5af27083cc5bdb.tar.gz
historical-0870dcee4101a4b0671890953b5af27083cc5bdb.tar.bz2
historical-0870dcee4101a4b0671890953b5af27083cc5bdb.zip
Add slot 3.0 from gnome overlay, bug #361127.
Package-Manager: portage-2.2.0_alpha30/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/gtksourceviewmm/gtksourceviewmm-3.0.0.ebuild')
-rw-r--r--dev-cpp/gtksourceviewmm/gtksourceviewmm-3.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.0.0.ebuild b/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.0.0.ebuild
new file mode 100644
index 000000000000..1c675c60f1c2
--- /dev/null
+++ b/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gtksourceviewmm/gtksourceviewmm-3.0.0.ebuild,v 1.1 2011/05/08 13:59:38 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for gtksourceview"
+HOMEPAGE="http://projects.gnome.org/gtksourceviewmm/"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+SLOT="3.0"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-cpp/glibmm-2.28:2
+ >=dev-cpp/gtkmm-3:3.0
+ >=x11-libs/gtksourceview-3:3.0
+
+ dev-cpp/atkmm
+ dev-cpp/cairomm
+ dev-cpp/pangomm:1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+ G2CONF="${G2CONF} $(use_enable doc documentation)"
+}