summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-01-16 16:24:09 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-01-16 16:24:09 +0000
commit6f385de4f63569763aaebcd4bdf4a26e8b5dc7e3 (patch)
treea277e9f614d71e3cc9b9122edbded5ae0794abae /dev-cpp/libpqpp
parentVersion bump. (diff)
downloadhistorical-6f385de4f63569763aaebcd4bdf4a26e8b5dc7e3.tar.gz
historical-6f385de4f63569763aaebcd4bdf4a26e8b5dc7e3.tar.bz2
historical-6f385de4f63569763aaebcd4bdf4a26e8b5dc7e3.zip
Moved category and renamed package name.
Diffstat (limited to 'dev-cpp/libpqpp')
-rw-r--r--dev-cpp/libpqpp/ChangeLog25
-rw-r--r--dev-cpp/libpqpp/Manifest7
-rw-r--r--dev-cpp/libpqpp/files/digest-libpqpp-4.0-r11
-rw-r--r--dev-cpp/libpqpp/files/digest-libpqpp-4.0-r21
-rw-r--r--dev-cpp/libpqpp/files/libpqpp-4.0-gentoo.patch95
-rw-r--r--dev-cpp/libpqpp/libpqpp-4.0-r1.ebuild37
-rw-r--r--dev-cpp/libpqpp/libpqpp-4.0-r2.ebuild36
-rw-r--r--dev-cpp/libpqpp/metadata.xml5
8 files changed, 207 insertions, 0 deletions
diff --git a/dev-cpp/libpqpp/ChangeLog b/dev-cpp/libpqpp/ChangeLog
new file mode 100644
index 000000000000..ceabdd7a6a0a
--- /dev/null
+++ b/dev-cpp/libpqpp/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for dev-cpp/libpqpp
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libpqpp/ChangeLog,v 1.1 2004/01/16 16:24:09 nakano Exp $
+
+*libpqpp-4.0-r2 (16 Jan 2004)
+
+ 16 Jan 2004; Masatomo Nakano <nakano@gentoo.org> libpqpp-4.0-r1.ebuild,
+ libpqpp-4.0-r2.ebuild, metadata.xml, files/libpqpp-4.0-gentoo.patch:
+ Moved category and renamed package name. And fixed PostgreSQL dirs as -r2.
+
+*libpq++-4.0-r1 (19 Jul 2003)
+
+ 19 Jul 2003; jje <jje@gentoo.org> libpq++-4.0-r1.ebuild,
+ files/libpq++-gentoo.patch:
+ Added patch to remove DLLIMPORT defines.
+
+*libpq++-4.0 (16 Jun 2003)
+
+ 12 Jul 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Added missing changelog entry.
+
+ 16 Jun 2003; Masatomo Nakano <nakano@gentoo.org> :
+ Initial import. Thanks to marco <marco@md2.ath.cx>
+ #21737
+
diff --git a/dev-cpp/libpqpp/Manifest b/dev-cpp/libpqpp/Manifest
new file mode 100644
index 000000000000..7207f1d83946
--- /dev/null
+++ b/dev-cpp/libpqpp/Manifest
@@ -0,0 +1,7 @@
+MD5 83d022d0638b99d5d652e61578d204e7 libpqpp-4.0-r2.ebuild 1114
+MD5 c22c513717ccacbd49026199cfcf1ce9 ChangeLog 859
+MD5 f8d3d207746da2a3cd14dcaab8daab76 metadata.xml 163
+MD5 ee5962ebdb90abd8691a90096e764361 libpqpp-4.0-r1.ebuild 1075
+MD5 312b07ad4bf840d75840b7410d48f268 files/digest-libpqpp-4.0-r1 62
+MD5 530daffcb76569636aa08cb163318b88 files/libpqpp-4.0-gentoo.patch 3559
+MD5 312b07ad4bf840d75840b7410d48f268 files/digest-libpqpp-4.0-r2 62
diff --git a/dev-cpp/libpqpp/files/digest-libpqpp-4.0-r1 b/dev-cpp/libpqpp/files/digest-libpqpp-4.0-r1
new file mode 100644
index 000000000000..b94211985780
--- /dev/null
+++ b/dev-cpp/libpqpp/files/digest-libpqpp-4.0-r1
@@ -0,0 +1 @@
+MD5 da71cb79ef45cef55f4bc97a33a0857d libpq++-4.0.tar.gz 25809
diff --git a/dev-cpp/libpqpp/files/digest-libpqpp-4.0-r2 b/dev-cpp/libpqpp/files/digest-libpqpp-4.0-r2
new file mode 100644
index 000000000000..b94211985780
--- /dev/null
+++ b/dev-cpp/libpqpp/files/digest-libpqpp-4.0-r2
@@ -0,0 +1 @@
+MD5 da71cb79ef45cef55f4bc97a33a0857d libpq++-4.0.tar.gz 25809
diff --git a/dev-cpp/libpqpp/files/libpqpp-4.0-gentoo.patch b/dev-cpp/libpqpp/files/libpqpp-4.0-gentoo.patch
new file mode 100644
index 000000000000..9f54fb43edb9
--- /dev/null
+++ b/dev-cpp/libpqpp/files/libpqpp-4.0-gentoo.patch
@@ -0,0 +1,95 @@
+*** pgconnection.h Sat Jul 19 14:45:30 2003
+--- pgconnection.h.orig Sat Jul 19 14:44:18 2003
+***************
+*** 45,51 ****
+ // This class contains all the information about the connection
+ // to the backend process. All the database classes should be
+ // derived from this class to obtain the connection interface.
+! class DLLIMPORT PgConnection
+ {
+ protected:
+ PGconn* pgConn; // Connection Structure
+--- 45,51 ----
+ // This class contains all the information about the connection
+ // to the backend process. All the database classes should be
+ // derived from this class to obtain the connection interface.
+! class PgConnection
+ {
+ protected:
+ PGconn* pgConn; // Connection Structure
+*** pgcursordb.h Sat Jul 19 14:45:38 2003
+--- pgcursordb.h.orig Sat Jul 19 14:44:32 2003
+***************
+*** 41,47 ****
+ // manipulates data through it. The interface will introduce some
+ // ease of use through the methods that will allow cursor specific
+ // operations, like fetch, forward, etc.
+! class DLLIMPORT PgCursor : public PgTransaction
+ {
+ public:
+ PgCursor(const char* conninfo, const char* cursor); // use reasonable & environment defaults
+--- 41,47 ----
+ // manipulates data through it. The interface will introduce some
+ // ease of use through the methods that will allow cursor specific
+ // operations, like fetch, forward, etc.
+! class PgCursor : public PgTransaction
+ {
+ public:
+ PgCursor(const char* conninfo, const char* cursor); // use reasonable & environment defaults
+*** pglobject.h Sat Jul 19 14:45:57 2003
+--- pglobject.h.orig Sat Jul 19 14:44:57 2003
+***************
+*** 35,41 ****
+ // PgLargeObject - a class for accessing Large Object in a database
+ //
+ // ****************************************************************
+! class DLLIMPORT PgLargeObject : public PgConnection
+ {
+ private:
+ int pgFd;
+--- 35,41 ----
+ // PgLargeObject - a class for accessing Large Object in a database
+ //
+ // ****************************************************************
+! class PgLargeObject : public PgConnection
+ {
+ private:
+ int pgFd;
+*** pgtransdb.h Sat Jul 19 14:46:07 2003
+--- pgtransdb.h.orig Sat Jul 19 14:45:07 2003
+***************
+*** 35,41 ****
+ // transaction block during its lifetime. The block is ABORTed when
+ // the object is destroyed, unless you call EndTransaction() method
+ // before destruction of the object.
+! class DLLIMPORT PgTransaction : public PgDatabase
+ {
+ public:
+ explicit PgTransaction(const char* conninfo); // use reasonable & environment defaults
+--- 35,41 ----
+ // transaction block during its lifetime. The block is ABORTed when
+ // the object is destroyed, unless you call EndTransaction() method
+ // before destruction of the object.
+! class PgTransaction : public PgDatabase
+ {
+ public:
+ explicit PgTransaction(const char* conninfo); // use reasonable & environment defaults
+*** pgdatabase.h Sat Jul 19 14:57:39 2003
+--- pgdatabase.h.orig Sat Jul 19 14:57:18 2003
+***************
+*** 34,40 ****
+ // This is the basic database access class. Its interface should
+ // be used only after a query has been sent to the backend and
+ // results are being received.
+! class DLLIMPORT PgDatabase : public PgConnection
+ {
+ public:
+ // connect to the database with conninfo
+--- 34,40 ----
+ // This is the basic database access class. Its interface should
+ // be used only after a query has been sent to the backend and
+ // results are being received.
+! class PgDatabase : public PgConnection
+ {
+ public:
+ // connect to the database with conninfo
diff --git a/dev-cpp/libpqpp/libpqpp-4.0-r1.ebuild b/dev-cpp/libpqpp/libpqpp-4.0-r1.ebuild
new file mode 100644
index 000000000000..f94a79516b49
--- /dev/null
+++ b/dev-cpp/libpqpp/libpqpp-4.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libpqpp/libpqpp-4.0-r1.ebuild,v 1.1 2004/01/16 16:24:09 nakano Exp $
+
+DESCRIPTION="C++ wrapper for the libpq Postgresql library"
+HOMEPAGE="http://gborg.postgresql.org/"
+SRC_URI="ftp://gborg.postgresql.org/pub/libpqpp/stable/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc"
+RDEPEND=">=dev-db/postgresql-7.3"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gentoo.patch
+}
+
+src_compile() {
+ sed "s|^POSTGRES_HOME=/usr/local/pgsql$|POSTGRES_HOME=/usr|g" Makefile > Makefile.new &&
+ mv Makefile.new Makefile
+ emake
+ sed "s|^POSTGRES_HOME=/usr$|POSTGRES_HOME=\${D}usr|g" Makefile > Makefile.new &&
+ mv Makefile.new Makefile
+ sed "s|^\tln -s .*$|\tln -s \$(soname) \$(POSTGRES_HOME)/lib/\$(TARGET).so|g" Makefile > Makefile.new &&
+ mv Makefile.new Makefile
+ emake
+}
+
+src_install() {
+ dodir /usr/lib /usr/include
+ einstall install || die "Install failed"
+}
diff --git a/dev-cpp/libpqpp/libpqpp-4.0-r2.ebuild b/dev-cpp/libpqpp/libpqpp-4.0-r2.ebuild
new file mode 100644
index 000000000000..f23df25a6222
--- /dev/null
+++ b/dev-cpp/libpqpp/libpqpp-4.0-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libpqpp/libpqpp-4.0-r2.ebuild,v 1.1 2004/01/16 16:24:09 nakano Exp $
+
+MY_P=${P/pp/++}
+DESCRIPTION="C++ wrapper for the libpq Postgresql library"
+HOMEPAGE="http://gborg.postgresql.org/"
+SRC_URI="ftp://gborg.postgresql.org/pub/libpqpp/stable/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc >=dev-db/postgresql-7.3"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ cp Makefile Makefile.backup
+ sed -i "s|\$(POSTGRES_HOME)/lib|/usr/lib/postgresql|g" Makefile || die
+ sed -i "s|\$(POSTGRES_HOME)/include|/usr/include/postgresql|g" Makefile || die
+ emake || die
+ cp Makefile.backup Makefile
+}
+
+src_install() {
+ sed -i "s|\$(POSTGRES_HOME)/lib|${D}/usr/lib/postgresql|g" Makefile || die
+ sed -i "s|\$(POSTGRES_HOME)/include|${D}/usr/include/postgresql|g" Makefile || die
+ dodir /usr/lib/postgresql /usr/include/postgresql
+ einstall || die "Install failed"
+}
diff --git a/dev-cpp/libpqpp/metadata.xml b/dev-cpp/libpqpp/metadata.xml
new file mode 100644
index 000000000000..309b51e9a965
--- /dev/null
+++ b/dev-cpp/libpqpp/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>postgresql</herd>
+</pkgmetadata>