summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2008-05-03 18:57:05 +0000
committerHanno Boeck <hanno@gentoo.org>2008-05-03 18:57:05 +0000
commit692ec9e69d8eed4b2cb5708d877a3b4e2fd09e66 (patch)
tree3c57ef512e0d2d60790a4aa062f9ca5629c21117 /dev-cpp/libthrowable/libthrowable-1.1.0.ebuild
parentRemove mask on bind(-tools) 9.2.7 and 9.3.3 (diff)
downloadhistorical-692ec9e69d8eed4b2cb5708d877a3b4e2fd09e66.tar.gz
historical-692ec9e69d8eed4b2cb5708d877a3b4e2fd09e66.tar.bz2
historical-692ec9e69d8eed4b2cb5708d877a3b4e2fd09e66.zip
libthrowable: fix for gcc43
Package-Manager: portage-2.1.5_rc6
Diffstat (limited to 'dev-cpp/libthrowable/libthrowable-1.1.0.ebuild')
-rw-r--r--dev-cpp/libthrowable/libthrowable-1.1.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-cpp/libthrowable/libthrowable-1.1.0.ebuild b/dev-cpp/libthrowable/libthrowable-1.1.0.ebuild
index 5a12f860422b..63c590d26828 100644
--- a/dev-cpp/libthrowable/libthrowable-1.1.0.ebuild
+++ b/dev-cpp/libthrowable/libthrowable-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libthrowable/libthrowable-1.1.0.ebuild,v 1.3 2008/05/02 15:05:05 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libthrowable/libthrowable-1.1.0.ebuild,v 1.4 2008/05/03 18:57:04 hanno Exp $
inherit eutils
@@ -28,6 +28,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/libthrowable-1.1.0-gcc43.diff"
+}
+
src_compile() {
econf $(use_enable threads pthreads) || die "econf failed"
emake || die "emake failed"