summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2012-08-23 13:40:52 +0000
committerTiziano Müller <dev-zero@gentoo.org>2012-08-23 13:40:52 +0000
commit867ca6fbb4f8ce1eb93749fbda968ab40bb762d3 (patch)
tree79eec158ec0cf32f39a8c976c34074df62930f81 /dev-cpp/xsd/xsd-3.3.0.ebuild
parentvanilla-2.6.32.59 + genpatches-2.6.32-48 + grsecurity-2.9.1-2.6.32.59-2012082... (diff)
downloadhistorical-867ca6fbb4f8ce1eb93749fbda968ab40bb762d3.tar.gz
historical-867ca6fbb4f8ce1eb93749fbda968ab40bb762d3.tar.bz2
historical-867ca6fbb4f8ce1eb93749fbda968ab40bb762d3.zip
Fix compatibility with boost >=1.49.0 (filesystem v2 gone), bug #425426.
Package-Manager: portage-2.1.11.9/cvs/Linux x86_64
Diffstat (limited to 'dev-cpp/xsd/xsd-3.3.0.ebuild')
-rw-r--r--dev-cpp/xsd/xsd-3.3.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-cpp/xsd/xsd-3.3.0.ebuild b/dev-cpp/xsd/xsd-3.3.0.ebuild
index 6a47d8db6d66..e0c5bf78b22b 100644
--- a/dev-cpp/xsd/xsd-3.3.0.ebuild
+++ b/dev-cpp/xsd/xsd-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/xsd/xsd-3.3.0.ebuild,v 1.3 2012/06/01 20:52:32 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/xsd/xsd-3.3.0.ebuild,v 1.4 2012/08/23 13:40:52 dev-zero Exp $
EAPI="2"
@@ -30,7 +30,8 @@ src_prepare() {
"${FILESDIR}/${PV}-disable_examples_and_tests.patch" \
"${FILESDIR}/${PV}-xsdcxx-rename.patch" \
"${FILESDIR}/${PV}-fix_include.patch" \
- "${FILESDIR}/${PV}-fix_tests.patch"
+ "${FILESDIR}/${PV}-fix_tests.patch" \
+ "${FILESDIR}/${PV}-boost-filesystem-v2-deprecation.patch"
}
use_yesno() {
@@ -65,7 +66,7 @@ cxx_id := gnu
cxx_optimize := n
cxx_debug := n
cxx_rpath := n
-cxx_pp_extra_options := -DBOOST_FILESYSTEM_VERSION=2
+cxx_pp_extra_options :=
cxx_extra_options := ${CXXFLAGS} -I${BOOST_INC}
cxx_ld_extra_options := ${LDFLAGS}
cxx_extra_libs :=