summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-05-06 20:46:32 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-05-06 20:46:32 +0000
commitaf774c57b4c8e2fe8178bef131d8de0517fd6ad5 (patch)
tree151564db434bef8ed3a0467dbd1fb23ce44a6f6e /dev-db/sqlite/sqlite-3.3.5-r1.ebuild
parentIgnore output of renice command. (diff)
downloadhistorical-af774c57b4c8e2fe8178bef131d8de0517fd6ad5.tar.gz
historical-af774c57b4c8e2fe8178bef131d8de0517fd6ad5.tar.bz2
historical-af774c57b4c8e2fe8178bef131d8de0517fd6ad5.zip
Skip tests gracefully, based on my changes last time. Also, migrate those changes to the two sqlite-2 ebuilds.
Package-Manager: portage-2.1_pre9-r5
Diffstat (limited to 'dev-db/sqlite/sqlite-3.3.5-r1.ebuild')
-rw-r--r--dev-db/sqlite/sqlite-3.3.5-r1.ebuild27
1 files changed, 17 insertions, 10 deletions
diff --git a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
index 7d8a2dd479ae..75ae9428c6d2 100644
--- a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.2 2006/05/04 13:00:38 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.3 2006/05/06 20:46:32 seemant Exp $
inherit eutils alternatives
@@ -71,21 +71,28 @@ src_compile() {
emake all || die
if use doc; then
- emake doc
+ emake doc
fi
}
src_test() {
- cd ${S}
- if use debug; then
- emake fulltest || die "some test failed"
- else
- emake test || die "some test failed"
+ if use tcltk ; then
+ if has usepriv ${FEATURES} ; then
+ cd ${S}
+ if use debug; then
+ emake fulltest || die "some test failed"
+ else
+ emake test || die "some test failed"
+ fi
+ fi
fi
}
src_install () {
- make DESTDIR="${D}" TCLLIBDIR="/usr/$(get_libdir)" install || die
+ make \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)" \
+ install || die
newbin lemon lemon-${SLOT}
@@ -93,7 +100,7 @@ src_install () {
doman sqlite3.1
if use doc; then
- docinto html
- dohtml doc/*.html doc/*.txt doc/*.png
+ docinto html
+ dohtml doc/*.html doc/*.txt doc/*.png
fi
}