summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-09 18:41:21 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-09 18:41:21 +0000
commit97f1867698ccd1a5bc892d15786f4996ccc2d7e4 (patch)
tree9e8137df1d6e70bdb04eca11927031165fe6b0dd /dev-db/unixODBC/unixODBC-2.2.2.ebuild
parentVersion bump; added documentation; lintool'd and repoman'd; added SLOT and KE... (diff)
downloadhistorical-97f1867698ccd1a5bc892d15786f4996ccc2d7e4.tar.gz
historical-97f1867698ccd1a5bc892d15786f4996ccc2d7e4.tar.bz2
historical-97f1867698ccd1a5bc892d15786f4996ccc2d7e4.zip
New version. Fixes #2179
Diffstat (limited to 'dev-db/unixODBC/unixODBC-2.2.2.ebuild')
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.2.2.ebuild b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
new file mode 100644
index 000000000000..42f110cb5283
--- /dev/null
+++ b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.1 2002/07/09 18:41:21 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ODBC Interface for Linux"
+SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
+HOMEPAGE="http://www.unixodbc.org"
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ qt? ( >=x11-libs/qt-3.0* )"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Original Makefile.in is trying to create and install files directly in /etc so we
+ # need to edit the file to make it DESTDIR sensitive.
+ cp Makefile.in Makefile.orig
+ sed -e "s:touch :touch \${DESTDIR}/:" -e "s:mkdir -p :mkdir -p \${DESTDIR}/:" Makefile.orig > Makefile.in
+}
+
+src_compile() {
+ local myconf
+
+ if [ "`use qt`" ]
+ then
+ myconf="--enable-gui=yes"
+ else
+ myconf="--enable-gui=no"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README*
+ cp -a doc ${D}/usr/share/doc/${PF}/html
+ find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ prepalldocs
+}