summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-22 21:41:16 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-22 21:41:16 +0000
commit88dc553740c6fce41d281f48e80e61c8f9151893 (patch)
tree699ef59ced9d78fa0d09450c98342e6c919e4190 /dev-db
parent*** empty log message *** (diff)
downloadhistorical-88dc553740c6fce41d281f48e80e61c8f9151893.tar.gz
historical-88dc553740c6fce41d281f48e80e61c8f9151893.tar.bz2
historical-88dc553740c6fce41d281f48e80e61c8f9151893.zip
*** empty log message ***
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/files/digest-mysql-3.23.221
-rw-r--r--dev-db/mysql/mysql-3.23.22.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/dev-db/mysql/files/digest-mysql-3.23.22 b/dev-db/mysql/files/digest-mysql-3.23.22
new file mode 100644
index 000000000000..b61483f2d317
--- /dev/null
+++ b/dev-db/mysql/files/digest-mysql-3.23.22
@@ -0,0 +1 @@
+MD5 dfb40c467219de80ed767ad372e34acf mysql-3.23.22-beta.tar.gz
diff --git a/dev-db/mysql/mysql-3.23.22.ebuild b/dev-db/mysql/mysql-3.23.22.ebuild
new file mode 100644
index 000000000000..0ba96cc08599
--- /dev/null
+++ b/dev-db/mysql/mysql-3.23.22.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.22.ebuild,v 1.1 2000/08/22 21:41:16 achim Exp $
+
+P=mysql-3.23.22-beta
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The MySQL Database"
+SRC_URI="http://www.mysql.com/Downloads/MySQL-3.23/${A}"
+HOMEPAGE="http://www.mysql.com/"
+
+
+src_compile() {
+ if [ "$PLATFORM" = "i686-pc-linux-gnu" ]
+ then
+ export CFLAGS="-mpentium"
+ export CXXFLAGS="-mpentium"
+ fi
+ # Patch for qmail-mysql
+ cd ${S}/include
+ cp nisam.h nisam.h.orig
+ sed -e "s/define N_MAX_KEY_LENGTH 256/define N_MAX_KEY_LENGTH 500/" nisam.h.orig > nisam.h
+
+ cd ${S}
+ CXX=gcc ./configure --prefix=/usr --host=${CHOST} \
+ --enable-shared \
+ --enable-static \
+ --enable-assembler \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/sbin \
+ --sysconfdir=/etc/mysql \
+ --localstatedir=/var/mysql \
+ --infodir=/usr/info \
+ --mandir=/usr/man \
+ --without-debug \
+ --with-mysql-user=mysql
+ make benchdir=/usr/share/mysql-bench
+}
+
+src_install() {
+
+ cd ${S}
+
+ # Install MySQL
+
+ make install prefix=${D}/usr \
+ libdir=${D}/usr/lib \
+ libexecdir=${D}/usr/sbin \
+ sysconfdir=${D}/etc/mysql \
+ localstatedir=${D}/var/mysql \
+ infodir=${D}/usr/info \
+ mandir=${D}/usr/man \
+ benchdir=${D}/usr/share/mysql-bench
+
+ prepman
+ prepinfo
+
+ # Move Client Libs
+ mv ${D}/usr/lib/mysql/libmysqlclient.so* ${D}/usr/lib
+
+ into /
+ dodir /etc/mysql
+ cp scripts/mysqlaccess.conf ${D}/etc/mysql
+ cp ${O}/files/my.cnf ${D}/etc/mysql
+
+ dodir /etc/rc.d/init.d
+ cp ${O}/files/mysql ${D}/etc/rc.d/init.d/mysql
+
+ # MySQL Docs
+
+ cd ${S}
+ into /usr
+ dodoc INSTALL-SOURCE INSTALL-SOURCE-GENERIC README PUBLIC MIRRORS
+ cd ${S}/Docs
+ dodoc INSTALL-BINARY manual.ps manual.txt
+ docinto html
+ dodoc manual.html manual_toc.html
+ docinto html/Img
+ dodoc Img/*.gif
+
+}
+
+pkg_config () {
+
+ echo "Setting up symlinks..."
+ ${ROOT}/usr/sbin/rc-update add mysql
+
+}
+
+
+
+
+
+