summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2005-05-09 21:38:07 +0000
committerMasatomo Nakano <nakano@gentoo.org>2005-05-09 21:38:07 +0000
commitfd4dac80432c661e9bac58f84fc7dab908530acb (patch)
tree3a14b98560160ade062fc60821f91fdaf2d1317e /dev-db
parentVersion bump (diff)
downloadhistorical-fd4dac80432c661e9bac58f84fc7dab908530acb.tar.gz
historical-fd4dac80432c661e9bac58f84fc7dab908530acb.tar.bz2
historical-fd4dac80432c661e9bac58f84fc7dab908530acb.zip
Added missing include files.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libpq/ChangeLog6
-rw-r--r--dev-db/libpq/Manifest6
-rw-r--r--dev-db/libpq/libpq-3.2.ebuild26
-rw-r--r--dev-db/libpq/libpq-4.0.ebuild26
4 files changed, 44 insertions, 20 deletions
diff --git a/dev-db/libpq/ChangeLog b/dev-db/libpq/ChangeLog
index a9412a9eee5f..bc2d52ce214a 100644
--- a/dev-db/libpq/ChangeLog
+++ b/dev-db/libpq/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/libpq
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.2 2005/05/08 23:00:24 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/ChangeLog,v 1.3 2005/05/09 21:38:07 nakano Exp $
+
+ 09 May 2005; Masatomo Nakano <nakano@gentoo.org> libpq-3.2.ebuild,
+ libpq-4.0.ebuild:
+ Added missing include files.
08 May 2005; Masatomo Nakano <nakano@gentoo.org> libpq-3.2.ebuild,
libpq-4.0.ebuild:
diff --git a/dev-db/libpq/Manifest b/dev-db/libpq/Manifest
index 9088ef9686c8..106766d4df42 100644
--- a/dev-db/libpq/Manifest
+++ b/dev-db/libpq/Manifest
@@ -1,6 +1,6 @@
-MD5 d789ce1f0c289d37ebaafe6fb4de1212 libpq-3.2.ebuild 2758
-MD5 d6bee7c5005b327684a706bfe5cc1bcb libpq-4.0.ebuild 2758
-MD5 f9813b10aab7b581b21fcfa501274c09 ChangeLog 548
+MD5 e8990a5be7de6a0bc73ff6ec53d869c4 libpq-3.2.ebuild 2867
+MD5 17574c69b3319df0f21ab1789cfdaca4 libpq-4.0.ebuild 2867
+MD5 adc882481aa3ad05048b8bc1b4d70a5c ChangeLog 669
MD5 f8d3d207746da2a3cd14dcaab8daab76 metadata.xml 163
MD5 637716f510743dd4c21c51980eb76659 files/libpq-3.2-gentoo.patch 2300
MD5 5f9040f91914a9aba8ebee9bff295909 files/libpq-4.0-gentoo.patch 2300
diff --git a/dev-db/libpq/libpq-3.2.ebuild b/dev-db/libpq/libpq-3.2.ebuild
index 78dac6a05175..a9d4b85378ed 100644
--- a/dev-db/libpq/libpq-3.2.ebuild
+++ b/dev-db/libpq/libpq-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-3.2.ebuild,v 1.2 2005/05/08 23:00:24 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-3.2.ebuild,v 1.3 2005/05/09 21:38:07 nakano Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -74,15 +74,25 @@ src_install() {
cd ${S}/src/interfaces/libpq
make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}/src/include
+ make DESTDIR=${D} install || die
+
cd ${S}
dodoc README HISTORY COPYRIGHT INSTALL
- cp src/include/postgres_ext.h ${D}/usr/include/postgresql/libpq-${SLOT}
-
dosym /usr/lib/libpq-${SLOT}.a /usr/lib/libpq.a
- dodir /usr/include/postgresql/internal/
- dosym /usr/include/postgresql/libpq-${SLOT}/libpq-fe.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/postgres_ext.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/libpq-int.h /usr/include/postgresql/internal/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/pqexpbuffer.h /usr/include/postgresql/internal/
+
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/*.h ${D}/usr/include/
+
+ dodir /usr/include/libpq
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/libpq/*.h ${D}/usr/include/libpq
+
+ cd ${D}/usr/include/postgresql/libpq-${SLOT}
+ for f in $(find . -name '*.h' -print) ; do
+ destdir=$(dirname $f)
+ if [ ! -d "${D}/usr/include/postgresql/${destdir}" ]; then
+ mkdir -p ${D}/usr/include/postgresql/${destdir}
+ fi
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/${f} ${D}/usr/include/postgresql/${destdir}/
+ done
}
diff --git a/dev-db/libpq/libpq-4.0.ebuild b/dev-db/libpq/libpq-4.0.ebuild
index edb84dc6ea2a..c43c6db6a8b4 100644
--- a/dev-db/libpq/libpq-4.0.ebuild
+++ b/dev-db/libpq/libpq-4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-4.0.ebuild,v 1.2 2005/05/08 23:00:24 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libpq/libpq-4.0.ebuild,v 1.3 2005/05/09 21:38:07 nakano Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -74,15 +74,25 @@ src_install() {
cd ${S}/src/interfaces/libpq
make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}/src/include
+ make DESTDIR=${D} install || die
+
cd ${S}
dodoc README HISTORY COPYRIGHT INSTALL
- cp src/include/postgres_ext.h ${D}/usr/include/postgresql/libpq-${SLOT}
-
dosym /usr/lib/libpq-${SLOT}.a /usr/lib/libpq.a
- dodir /usr/include/postgresql/internal/
- dosym /usr/include/postgresql/libpq-${SLOT}/libpq-fe.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/postgres_ext.h /usr/include/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/libpq-int.h /usr/include/postgresql/internal/
- dosym /usr/include/postgresql/libpq-${SLOT}/internal/pqexpbuffer.h /usr/include/postgresql/internal/
+
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/*.h ${D}/usr/include/
+
+ dodir /usr/include/libpq
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/libpq/*.h ${D}/usr/include/libpq
+
+ cd ${D}/usr/include/postgresql/libpq-${SLOT}
+ for f in $(find . -name '*.h' -print) ; do
+ destdir=$(dirname $f)
+ if [ ! -d "${D}/usr/include/postgresql/${destdir}" ]; then
+ mkdir -p ${D}/usr/include/postgresql/${destdir}
+ fi
+ ln -s ${D}/usr/include/postgresql/libpq-${SLOT}/${f} ${D}/usr/include/postgresql/${destdir}/
+ done
}