summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-11-08 04:06:32 +0000
committerPeter Johanson <latexer@gentoo.org>2005-11-08 04:06:32 +0000
commita2a0772aa32ac2b402e6593dad191d269db61fa7 (patch)
treee593a934bd5e2e808487beae0e4638a566e5abf1 /dev-dotnet/gconf-sharp/gconf-sharp-2.4.0.ebuild
parentRemove trailing whitespace (diff)
downloadhistorical-a2a0772aa32ac2b402e6593dad191d269db61fa7.tar.gz
historical-a2a0772aa32ac2b402e6593dad191d269db61fa7.tar.bz2
historical-a2a0772aa32ac2b402e6593dad191d269db61fa7.zip
Final releases of new *-sharp-2.4 and 2.6 stuff, and remove one older pre-release of both.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-dotnet/gconf-sharp/gconf-sharp-2.4.0.ebuild')
-rw-r--r--dev-dotnet/gconf-sharp/gconf-sharp-2.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-dotnet/gconf-sharp/gconf-sharp-2.4.0.ebuild b/dev-dotnet/gconf-sharp/gconf-sharp-2.4.0.ebuild
new file mode 100644
index 000000000000..6a20cea44968
--- /dev/null
+++ b/dev-dotnet/gconf-sharp/gconf-sharp-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gconf-sharp/gconf-sharp-2.4.0.ebuild,v 1.1 2005/11/08 04:04:46 latexer Exp $
+
+inherit gtk-sharp-component
+
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND="${DEPEND}
+ >=gnome-base/gconf-2.0
+ =dev-dotnet/glade-sharp-${PV}*
+ =dev-dotnet/gnome-sharp-${PV}*
+ =dev-dotnet/art-sharp-${PV}*"
+
+GTK_SHARP_COMPONENT_BUILD="gnome"
+GTK_SHARP_COMPONENT_BUILD_DEPS="art"
+GTK_SHARP_COMPONENT_SLOT="2"
+GTK_SHARP_COMPONENT_SLOT_DEC="-2.0"
+
+
+src_unpack() {
+ gtk-sharp-component_src_unpack
+
+ # Fix need as GConf.PropertyEditors references a locally built dll
+ sed -i "s:${GTK_SHARP_LIB_DIR}/gconf-sharp.dll:../GConf/gconf-sharp.dll:" \
+ ${S}/gconf/GConf.PropertyEditors/Makefile.in
+}