summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-06-29 17:40:16 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-06-29 17:40:16 +0000
commit4acac8387684a9dde20e6f3ecaab83ff367ad7d7 (patch)
tree64c59a5e2ad942777783c6b7e3c8b19489dd9288 /dev-embedded/scratchbox-devkit-git/scratchbox-devkit-git-1.0.2.ebuild
parentFix building with live ebuild (bug #323629); honor CC and LDFLAGS; make relea... (diff)
downloadhistorical-4acac8387684a9dde20e6f3ecaab83ff367ad7d7.tar.gz
historical-4acac8387684a9dde20e6f3ecaab83ff367ad7d7.tar.bz2
historical-4acac8387684a9dde20e6f3ecaab83ff367ad7d7.zip
Version bump (bug #325659). Thanks to David King <amigadave@amigadave.com> for the new ebuild.
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-embedded/scratchbox-devkit-git/scratchbox-devkit-git-1.0.2.ebuild')
-rw-r--r--dev-embedded/scratchbox-devkit-git/scratchbox-devkit-git-1.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-embedded/scratchbox-devkit-git/scratchbox-devkit-git-1.0.2.ebuild b/dev-embedded/scratchbox-devkit-git/scratchbox-devkit-git-1.0.2.ebuild
new file mode 100644
index 000000000000..01b670c7eb97
--- /dev/null
+++ b/dev-embedded/scratchbox-devkit-git/scratchbox-devkit-git-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox-devkit-git/scratchbox-devkit-git-1.0.2.ebuild,v 1.1 2010/06/29 17:38:39 ayoy Exp $
+
+SBOX_GROUP="sbox"
+
+DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
+HOMEPAGE="http://www.scratchbox.org/"
+SRC_URI="http://scratchbox.org/download/files/sbox-releases/hathor/tarball/${P}-i386.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Stripping BREAKS scratchbox, it runs in a chroot and is pre-stripped when needed (bug #296294)
+RESTRICT="strip"
+
+RDEPEND="=dev-embedded/scratchbox-1.0*"
+DEPEND=""
+
+TARGET_DIR="/opt/scratchbox"
+
+QA_TEXTRELS="opt/scratchbox"
+
+S=${WORKDIR}/scratchbox
+
+src_install() {
+ dodir ${TARGET_DIR}
+ cp -pRP * "${D}/${TARGET_DIR}"
+}