summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 00:42:07 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 00:42:07 +0000
commitfc96feec48e393966b2ff8d3131bfdd4f71447fa (patch)
tree8f4a1fae78ad3d4b5618bb04a190e6fe5e12214e /dev-haskell/cabal
parentalex-2.1 works with cabal 1.1.6 only, not cabal 1.2 (diff)
downloadhistorical-fc96feec48e393966b2ff8d3131bfdd4f71447fa.tar.gz
historical-fc96feec48e393966b2ff8d3131bfdd4f71447fa.tar.bz2
historical-fc96feec48e393966b2ff8d3131bfdd4f71447fa.zip
Various minor maintanance changes. Remove unecessary blocker.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/cabal')
-rw-r--r--dev-haskell/cabal/ChangeLog8
-rw-r--r--dev-haskell/cabal/cabal-1.1.3-r1.ebuild8
-rw-r--r--dev-haskell/cabal/cabal-1.1.4.ebuild11
-rw-r--r--dev-haskell/cabal/cabal-1.1.6.1.ebuild9
-rw-r--r--dev-haskell/cabal/cabal-1.1.6.2.ebuild40
5 files changed, 35 insertions, 41 deletions
diff --git a/dev-haskell/cabal/ChangeLog b/dev-haskell/cabal/ChangeLog
index 53bce4ff692f..78da627a4099 100644
--- a/dev-haskell/cabal/ChangeLog
+++ b/dev-haskell/cabal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/cabal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.35 2007/10/31 12:54:22 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.36 2007/12/13 00:42:07 dcoutts Exp $
+
+ 12 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> cabal-1.1.4.ebuild,
+ cabal-1.1.6.1.ebuild, cabal-1.1.6.2.ebuild:
+ Various minor maintanance changes. Remove unecessary blocker.
+ Use new eclass functions to reduce code. Tidy code layout.
+ Only install user guide if USE=doc.
31 Oct 2007; Duncan Coutts <dcoutts@gentoo.org> cabal-1.1.3-r1.ebuild,
cabal-1.1.4.ebuild, cabal-1.1.6.1.ebuild, cabal-1.1.6.2.ebuild:
diff --git a/dev-haskell/cabal/cabal-1.1.3-r1.ebuild b/dev-haskell/cabal/cabal-1.1.3-r1.ebuild
index 9314b0d85a08..45efb3ef6671 100644
--- a/dev-haskell/cabal/cabal-1.1.3-r1.ebuild
+++ b/dev-haskell/cabal/cabal-1.1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.3-r1.ebuild,v 1.12 2007/10/31 12:54:22 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.3-r1.ebuild,v 1.13 2007/12/13 00:42:07 dcoutts Exp $
CABAL_FEATURES="bootstrap lib"
inherit haskell-cabal eutils base
@@ -31,14 +31,14 @@ src_unpack() {
# Update: Seems that solving this upstream causes problems on Windows, so
# this hack will remain for now.
if $(ghc-cabal); then
- sed -i 's/Build-Depends: base, util/Build-Depends: base/' ${S}/Cabal.cabal
+ sed -i 's/Build-Depends: base, util/Build-Depends: base/' "${S}/Cabal.cabal"
else
- sed -i 's/Build-Depends: base, util/Build-Depends: base, unix/' ${S}/Cabal.cabal
+ sed -i 's/Build-Depends: base, util/Build-Depends: base, unix/' "${S}/Cabal.cabal"
fi
# patch to make installed packages be exposed by default with
# ghc 6.2.2 (which is Cabal's default with ghc 6.4.1)
- cd ${S}
+ cd "${S}"
epatch "${FILESDIR}/${PN}-1.1.3-ghc622.patch"
}
diff --git a/dev-haskell/cabal/cabal-1.1.4.ebuild b/dev-haskell/cabal/cabal-1.1.4.ebuild
index 015a32133ee1..28c1fdc640d4 100644
--- a/dev-haskell/cabal/cabal-1.1.4.ebuild
+++ b/dev-haskell/cabal/cabal-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.4.ebuild,v 1.11 2007/10/31 12:54:22 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.4.ebuild,v 1.12 2007/12/13 00:42:07 dcoutts Exp $
CABAL_FEATURES="bootstrap profile lib"
inherit haskell-cabal eutils base
@@ -15,8 +15,7 @@ KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="doc"
-DEPEND="<dev-lang/ghc-6.6
- !>=dev-lang/ghc-6.6"
+DEPEND="<dev-lang/ghc-6.6"
src_unpack() {
unpack ${A}
@@ -50,9 +49,9 @@ src_install() {
pkg_postinst () {
if ghc-cabal && ghc-package-exists "Cabal-1.0"; then
- ebegin "Unregistering ghc's built-in cabal "
- $(ghc-getghcpkg) unregister "Cabal-1.0" > /dev/null
- eend $?
+ ebegin "Unregistering ghc's built-in cabal "
+ $(ghc-getghcpkg) unregister "Cabal-1.0" > /dev/null
+ eend $?
fi
ghc-package_pkg_postinst
}
diff --git a/dev-haskell/cabal/cabal-1.1.6.1.ebuild b/dev-haskell/cabal/cabal-1.1.6.1.ebuild
index 44de6a2d54a5..5ce76446bf8c 100644
--- a/dev-haskell/cabal/cabal-1.1.6.1.ebuild
+++ b/dev-haskell/cabal/cabal-1.1.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.6.1.ebuild,v 1.4 2007/10/31 12:54:22 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.6.1.ebuild,v 1.5 2007/12/13 00:42:07 dcoutts Exp $
CABAL_FEATURES="bootstrap profile lib"
inherit haskell-cabal eutils
@@ -8,11 +8,10 @@ inherit haskell-cabal eutils
DESCRIPTION="Haskell Common Architecture for Building Applications and Libraries"
HOMEPAGE="http://haskell.org/cabal"
SRC_URI="http://haskell.org/cabal/release/${P}/${P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-
KEYWORDS="~alpha amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
IUSE="doc"
DEPEND=">=dev-lang/ghc-6.2"
@@ -21,7 +20,7 @@ src_unpack() {
unpack "${A}"
if ! $(ghc-cabal); then
sed -i 's/Build-Depends: base/Build-Depends: base, unix/' \
- ${S}/Cabal.cabal
+ "${S}/Cabal.cabal"
fi
}
@@ -39,8 +38,8 @@ src_install() {
cabal_src_install
# documentation (install directly)
- dohtml -r doc/users-guide
if use doc; then
+ dohtml -r doc/users-guide
dohtml -r doc/API
dohtml -r doc/pkg-spec-html
dodoc doc/pkg-spec.pdf
diff --git a/dev-haskell/cabal/cabal-1.1.6.2.ebuild b/dev-haskell/cabal/cabal-1.1.6.2.ebuild
index 6c10f55f7661..08fa7eaf0c12 100644
--- a/dev-haskell/cabal/cabal-1.1.6.2.ebuild
+++ b/dev-haskell/cabal/cabal-1.1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.6.2.ebuild,v 1.9 2007/10/31 12:54:22 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.1.6.2.ebuild,v 1.10 2007/12/13 00:42:07 dcoutts Exp $
CABAL_FEATURES="bootstrap profile lib"
inherit haskell-cabal eutils
@@ -8,31 +8,26 @@ inherit haskell-cabal eutils
DESCRIPTION="Haskell Common Architecture for Building Applications and Libraries"
HOMEPAGE="http://haskell.org/cabal"
SRC_URI="http://haskell.org/cabal/release/${P}/${P}.tar.gz"
+
LICENSE="as-is"
SLOT="0"
-
KEYWORDS="~alpha amd64 hppa ~ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
IUSE="doc"
DEPEND=">=dev-lang/ghc-6.2"
-GHC_PV="6.6.1"
+CABAL_CORE_LIB_GHC_PV="6.6.1"
src_unpack() {
- if test $(ghc-version) = ${GHC_PV}; then
- elog "cabal-${PV} is included in ghc-${GHC_PV}, nothing to install."
- else
- unpack "${A}"
- if ! $(ghc-cabal); then
- sed -i 's/Build-Depends: base/Build-Depends: base, unix/' \
- ${S}/Cabal.cabal
- fi
+ unpack "${A}"
+ if ! $(ghc-cabal); then
+ sed -i 's/Build-Depends: base/Build-Depends: base, unix/' \
+ "${S}/Cabal.cabal"
fi
}
src_compile() {
- if ! test $(ghc-version) = ${GHC_PV}; then
+ if ! cabal-is-dummy-lib; then
if ghc-cabal; then
make setup HC="$(ghc-getghc) -ignore-package Cabal"
else
@@ -44,19 +39,14 @@ src_compile() {
}
src_install() {
- if test $(ghc-version) = ${GHC_PV}; then
- dodir "$(ghc-confdir)"
- echo '[]' > "${D}/$(ghc-confdir)/$(ghc-localpkgconf)"
- else
- cabal_src_install
+ cabal_src_install
- # documentation (install directly)
+ # documentation (install directly)
+ if use doc; then
dohtml -r doc/users-guide
- if use doc; then
- dohtml -r doc/API
- dohtml -r doc/pkg-spec-html
- dodoc doc/pkg-spec.pdf
- fi
- dodoc changelog copyright README releaseNotes TODO
+ dohtml -r doc/API
+ dohtml -r doc/pkg-spec-html
+ dodoc doc/pkg-spec.pdf
fi
+ dodoc changelog copyright README releaseNotes TODO
}