summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-21 15:15:43 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-21 15:15:43 +0000
commitd1ab21c6a3ae70679b74f84a47cc56e55977db71 (patch)
tree7ad63cbaf25b06cdcd01a35f4dd6a695e9692df5 /dev-haskell/happy/happy-1.14.ebuild
parentinstall build_icon.sh #68399 by chico76 (diff)
downloadhistorical-d1ab21c6a3ae70679b74f84a47cc56e55977db71.tar.gz
historical-d1ab21c6a3ae70679b74f84a47cc56e55977db71.tar.bz2
historical-d1ab21c6a3ae70679b74f84a47cc56e55977db71.zip
patched for gcc-3.4
Diffstat (limited to 'dev-haskell/happy/happy-1.14.ebuild')
-rw-r--r--dev-haskell/happy/happy-1.14.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/dev-haskell/happy/happy-1.14.ebuild b/dev-haskell/happy/happy-1.14.ebuild
index c66f48124507..6001bd760647 100644
--- a/dev-haskell/happy/happy-1.14.ebuild
+++ b/dev-haskell/happy/happy-1.14.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.14.ebuild,v 1.3 2004/06/24 22:15:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.14.ebuild,v 1.4 2004/10/21 15:15:43 kosmikus Exp $
DESCRIPTION="A yacc-like parser generator for Haskell"
HOMEPAGE="http://haskell.org/happy/"
SRC_URI="http://haskell.cs.yale.edu/happy/dist/${PV}/${P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND="virtual/ghc"
RDEPEND=""
+inherit base eutils
+
src_unpack() {
- unpack ${A}
+ base_src_unpack
+ epatch "${FILESDIR}/${P}-gcc3.4.patch"
}
src_compile() {
- econf || die
-
- # "emake" does not work reliably. Probably due to the classic
- # dependency problem in make with parallel builds.
- make || die
+ econf || die "configure failed"
+ emake -j1 || die "make failed"
}
src_install() {
- einstall || die
+ einstall || die "installation failed"
}