summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 17:30:12 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 17:30:12 +0000
commit5202731a95bb3391e7b26ce4a954871bf285d750 (patch)
treea3bd7b5c05981965132e5151ba8a98a7e7678cc1 /dev-haskell/hdbc-sqlite
parentremove old versions (diff)
downloadhistorical-5202731a95bb3391e7b26ce4a954871bf285d750.tar.gz
historical-5202731a95bb3391e7b26ce4a954871bf285d750.tar.bz2
historical-5202731a95bb3391e7b26ce4a954871bf285d750.zip
New version.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/hdbc-sqlite')
-rw-r--r--dev-haskell/hdbc-sqlite/ChangeLog8
-rw-r--r--dev-haskell/hdbc-sqlite/files/digest-hdbc-sqlite-1.1.3.03
-rw-r--r--dev-haskell/hdbc-sqlite/files/hdbc-sqlite3-helper.h28
-rw-r--r--dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild44
4 files changed, 82 insertions, 1 deletions
diff --git a/dev-haskell/hdbc-sqlite/ChangeLog b/dev-haskell/hdbc-sqlite/ChangeLog
index 26f326bff515..16ee969e0e0e 100644
--- a/dev-haskell/hdbc-sqlite/ChangeLog
+++ b/dev-haskell/hdbc-sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hdbc-sqlite
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/ChangeLog,v 1.10 2007/10/31 13:01:36 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/ChangeLog,v 1.11 2007/12/13 17:20:20 dcoutts Exp $
+
+*hdbc-sqlite-1.1.3.0 (13 Dec 2007)
+
+ 13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org>
+ +files/hdbc-sqlite3-helper.h, +hdbc-sqlite-1.1.3.0.ebuild:
+ New version.
31 Oct 2007; Duncan Coutts <dcoutts@gentoo.org>
hdbc-sqlite-1.0.0.0.ebuild, hdbc-sqlite-1.0.1.0.ebuild:
diff --git a/dev-haskell/hdbc-sqlite/files/digest-hdbc-sqlite-1.1.3.0 b/dev-haskell/hdbc-sqlite/files/digest-hdbc-sqlite-1.1.3.0
new file mode 100644
index 000000000000..0ed5fde5f952
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite/files/digest-hdbc-sqlite-1.1.3.0
@@ -0,0 +1,3 @@
+MD5 8b430c17a2544d140cff879c392ba682 HDBC-sqlite3-1.1.3.0.tar.gz 17217
+RMD160 64b3485a7800e30d1c3c4c3488288873aca410f0 HDBC-sqlite3-1.1.3.0.tar.gz 17217
+SHA256 c75ed90c222b61867e8d2bc898e0bff17d56d7faefcdfbe25ded71564205901d HDBC-sqlite3-1.1.3.0.tar.gz 17217
diff --git a/dev-haskell/hdbc-sqlite/files/hdbc-sqlite3-helper.h b/dev-haskell/hdbc-sqlite/files/hdbc-sqlite3-helper.h
new file mode 100644
index 000000000000..4bd230b85b4a
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite/files/hdbc-sqlite3-helper.h
@@ -0,0 +1,28 @@
+#include <sqlite3.h>
+
+extern int sqlite3_bind_text2(sqlite3_stmt* a, int b, const char *c, int d);
+
+/* Clever trick: the obj is the first element in the struct, so the pointer
+ to the struct is the same as the pointer to the obj. */
+
+typedef struct TAG_finalizeonce {
+ void *encapobj;
+ int refcount;
+ int isfinalized;
+ struct TAG_finalizeonce *parent;
+} finalizeonce;
+
+
+extern int sqlite3_open2(const char *filename, finalizeonce **ppo);
+extern int sqlite3_close_app(finalizeonce *ppdb);
+extern void sqlite3_close_finalizer(finalizeonce *ppdb);
+extern void sqlite3_conditional_finalizer(finalizeonce *ppdb);
+
+extern void sqlite3_busy_timeout2(finalizeonce *ppdb, int ms);
+extern int sqlite3_prepare2(finalizeonce *fdb, const char *zSql,
+ int nBytes, finalizeonce **ppo,
+ const char **pzTail);
+extern int sqlite3_finalize_app(finalizeonce *ppst);
+extern void sqlite3_finalize_finalizer(finalizeonce *ppst);
+
+
diff --git a/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild
new file mode 100644
index 000000000000..df4eb73a2f35
--- /dev/null
+++ b/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-sqlite/hdbc-sqlite-1.1.3.0.ebuild,v 1.1 2007/12/13 17:20:20 dcoutts Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal versionator
+
+MY_PN=HDBC-sqlite3
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Sqlite v3 database driver for HDBC"
+HOMEPAGE="http://software.complete.org/hdbc-sqlite3"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+hdbc_PV=$(get_version_component_range 1-3)
+
+DEPEND=">=dev-lang/ghc-6.4.1
+ dev-haskell/mtl
+ =dev-haskell/hdbc-${hdbc_PV}*
+ >=dev-db/sqlite-3.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack "${A}"
+
+ cp "${FILESDIR}/hdbc-sqlite3-helper.h" "${S}/"
+ sed -i -e 's/GHC-Options: -O2 -Wall/GHC-Options: -fvia-C/' \
+ -e '/^Extensions:/a \
+ , ForeignFunctionInterface, EmptyDataDecls' \
+ "${S}/${MY_PN}.cabal"
+
+ if version_is_at_least "6.8" "$(ghc-version)"; then
+ sed -i -e '/Build-Depends:/a \
+ , bytestring' \
+ "${S}/${MY_PN}.cabal"
+ echo "GHC-Options: -XPatternSignatures" >> "${S}/${MY_PN}.cabal"
+ fi
+}