summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2014-03-12 20:55:34 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2014-03-12 20:55:34 +0000
commit7d4afbf186a7bf3ea37ce0c7d2a70e68b2b58d01 (patch)
tree619c9c83ec05d2092caa4f86527adf0315e7c7a6 /dev-haskell/tasty/tasty-0.7.ebuild
parentVersion bump, readline is needed when client is built (#504038 by Richard Li)... (diff)
downloadhistorical-7d4afbf186a7bf3ea37ce0c7d2a70e68b2b58d01.tar.gz
historical-7d4afbf186a7bf3ea37ce0c7d2a70e68b2b58d01.tar.bz2
historical-7d4afbf186a7bf3ea37ce0c7d2a70e68b2b58d01.zip
new versions
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0xEAD50D64D8D3571A!
Diffstat (limited to 'dev-haskell/tasty/tasty-0.7.ebuild')
-rw-r--r--dev-haskell/tasty/tasty-0.7.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/tasty/tasty-0.7.ebuild b/dev-haskell/tasty/tasty-0.7.ebuild
new file mode 100644
index 000000000000..bf1c894d59ee
--- /dev/null
+++ b/dev-haskell/tasty/tasty-0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/tasty-0.7.ebuild,v 1.1 2014/03/12 20:55:33 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="http://hackage.haskell.org/package/tasty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+colors"
+
+RDEPEND=">=dev-haskell/deepseq-1.3:=[profile?]
+ >=dev-haskell/either-4.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/optparse-applicative-0.6:=[profile?]
+ >=dev-haskell/regex-tdfa-1.1.8:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/tagged-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ colors? ( >=dev-haskell/ansi-terminal-0.6.1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag colors colors)
+}