summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-10 17:49:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-10 17:49:58 +0000
commit1dfb300ecf05a894932fc6cfdbbe31ad2d28c112 (patch)
tree6cd4bec592aba3c762bbfe324ede066186002559 /dev-haskell
parentFix unpacking of live git ebuilds. (diff)
downloadhistorical-1dfb300ecf05a894932fc6cfdbbe31ad2d28c112.tar.gz
historical-1dfb300ecf05a894932fc6cfdbbe31ad2d28c112.tar.bz2
historical-1dfb300ecf05a894932fc6cfdbbe31ad2d28c112.zip
Version bump.
Package-Manager: portage-2.2.0_alpha90_p1/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog10
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.0.5.ebuild34
-rw-r--r--dev-haskell/highlighting-kate/metadata.xml11
-rw-r--r--dev-haskell/pandoc-types/ChangeLog10
-rw-r--r--dev-haskell/pandoc-types/pandoc-types-1.9.1.ebuild24
-rw-r--r--dev-haskell/texmath/ChangeLog9
-rw-r--r--dev-haskell/texmath/texmath-0.6.0.3.ebuild45
7 files changed, 132 insertions, 11 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index 73d563e4e3a3..c128eb844db4 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/highlighting-kate
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.2 2011/05/03 19:17:20 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.3 2012/03/10 17:46:31 slyfox Exp $
+
+*highlighting-kate-0.5.0.5 (10 Mar 2012)
+
+ 10 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +highlighting-kate-0.5.0.5.ebuild, metadata.xml:
+ Version bump.
*highlighting-kate-0.2.9-r1 (03 May 2011)
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.0.5.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.0.5.ebuild
new file mode 100644
index 000000000000..59a68d3f811f
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.5.0.5.ebuild,v 1.1 2012/03/10 17:46:31 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2[profile?] <dev-haskell/blaze-html-0.5[profile?]
+ dev-haskell/mtl[profile?]
+ dev-haskell/parsec[profile?]
+ pcre-light? ( dev-haskell/pcre-light[profile?] )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin[profile?] )
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag executable) \
+ $(cabal_flag pcre-light)
+}
diff --git a/dev-haskell/highlighting-kate/metadata.xml b/dev-haskell/highlighting-kate/metadata.xml
index 6b7e545fd165..2c125555ada2 100644
--- a/dev-haskell/highlighting-kate/metadata.xml
+++ b/dev-haskell/highlighting-kate/metadata.xml
@@ -7,15 +7,16 @@
</maintainer>
<longdescription>
highlighting-kate is a syntax highlighting library
- with support for over one hundred languages. The syntax
+ with support for nearly one hundred languages. The syntax
parsers are automatically generated from Kate
- syntax descriptions (http://kate-editor.org/),
+ syntax descriptions (&lt;http://kate-editor.org/&gt;),
so any syntax supported by Kate can be added.
An (optional) command-line program is provided, along
with a utility for generating new parsers from Kate
XML syntax descriptions.
</longdescription>
- <use>
- <flag name="executable">Build the Highlight executable</flag>
- </use>
+<use>
+ <flag name='executable'>Build the Highlight executable.</flag>
+ <flag name='pcre-light'>Use the pcre-light library instead of regex-pcre-builtin.</flag>
+</use>
</pkgmetadata>
diff --git a/dev-haskell/pandoc-types/ChangeLog b/dev-haskell/pandoc-types/ChangeLog
index 6d7ab95fafd8..ccd0c3d9a79f 100644
--- a/dev-haskell/pandoc-types/ChangeLog
+++ b/dev-haskell/pandoc-types/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/pandoc-types
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-types/ChangeLog,v 1.1 2011/04/23 13:15:16 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-types/ChangeLog,v 1.2 2012/03/10 17:49:58 slyfox Exp $
+
+*pandoc-types-1.9.1 (10 Mar 2012)
+
+ 10 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +pandoc-types-1.9.1.ebuild:
+ Version bump.
*pandoc-types-1.8 (23 Apr 2011)
diff --git a/dev-haskell/pandoc-types/pandoc-types-1.9.1.ebuild b/dev-haskell/pandoc-types/pandoc-types-1.9.1.ebuild
new file mode 100644
index 000000000000..b4276df8ac72
--- /dev/null
+++ b/dev-haskell/pandoc-types/pandoc-types-1.9.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pandoc-types/pandoc-types-1.9.1.ebuild,v 1.1 2012/03/10 17:49:58 slyfox Exp $
+
+# ebuild generated by hackport 0.2.16.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Types for representing a structured document"
+HOMEPAGE="http://johnmacfarlane.net/pandoc"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/syb[profile?]
+ >=dev-lang/ghc-6.12.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/texmath/ChangeLog b/dev-haskell/texmath/ChangeLog
index 54306fba4088..ad383a1c81de 100644
--- a/dev-haskell/texmath/ChangeLog
+++ b/dev-haskell/texmath/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/texmath
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.1 2011/04/23 16:27:48 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/ChangeLog,v 1.2 2012/03/10 17:42:44 slyfox Exp $
+
+*texmath-0.6.0.3 (10 Mar 2012)
+
+ 10 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> +texmath-0.6.0.3.ebuild:
+ Version bump.
*texmath-0.5.0.1 (23 Apr 2011)
diff --git a/dev-haskell/texmath/texmath-0.6.0.3.ebuild b/dev-haskell/texmath/texmath-0.6.0.3.ebuild
new file mode 100644
index 000000000000..aeeb3de5aa4c
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.6.0.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.0.3.ebuild,v 1.1 2012/03/10 17:42:44 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="4"
+
+CABAL_FEATURES="bin lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion of LaTeX math formulas to MathML or OMML."
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgi test"
+
+RDEPEND=">=dev-haskell/parsec-2[profile?]
+ dev-haskell/syb[profile?]
+ >=dev-haskell/xml-1.3.12[profile?]
+ >=dev-lang/ghc-6.8.2
+ cgi? ( dev-haskell/json[profile?]
+ dev-haskell/cgi[profile?]
+ dev-haskell/utf8-string[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag cgi) \
+ $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove test and it's data
+ rm -f "${ED}/usr/bin/texmath" 2> /dev/null
+ rm -rf "${ED}/usr/share/${P}"/ghc-*/tests 2> /dev/null
+}