summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Almenar <strider@gentoo.org>2002-11-05 04:24:05 +0000
committerAdrian Almenar <strider@gentoo.org>2002-11-05 04:24:05 +0000
commit82ebbf31fc02ca0911c303724ba76ceabce17ba2 (patch)
tree98ce168a38f4a57db4f350bb02c47bc8ea163eec /dev-java/dom4j
parentTypo. (diff)
downloadhistorical-82ebbf31fc02ca0911c303724ba76ceabce17ba2.tar.gz
historical-82ebbf31fc02ca0911c303724ba76ceabce17ba2.tar.bz2
historical-82ebbf31fc02ca0911c303724ba76ceabce17ba2.zip
Removed KEYWORDS & cosmetic changes
Diffstat (limited to 'dev-java/dom4j')
-rw-r--r--dev-java/dom4j/ChangeLog6
-rw-r--r--dev-java/dom4j/dom4j-1.3.ebuild28
2 files changed, 19 insertions, 15 deletions
diff --git a/dev-java/dom4j/ChangeLog b/dev-java/dom4j/ChangeLog
index 11cbd33d2e42..4b629ab04385 100644
--- a/dev-java/dom4j/ChangeLog
+++ b/dev-java/dom4j/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-java/dom4j
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/dom4j/ChangeLog,v 1.1 2002/10/31 20:20:39 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dom4j/ChangeLog,v 1.2 2002/11/05 04:24:05 strider Exp $
*dom4j-1.3 (31 Oct 2002)
+ 04 Nov 2002; Adrian Almenar <strider@gentoo.org> dom4j-1.3.ebuild:
+ Changed KEYWORDS, removed other arch's cause i have not tested it
+ leaving only ~x86. Some cosmetic changes.
+
31 Oct 2002; Karl Trygve Kalleberg <karltk@gentoo.org> dom4j-1.3.ebuild files/digest-dom4j :
Initial import. Ebuild submitted by Adrian Almenar
<aalmenar@conectium.com>.
diff --git a/dev-java/dom4j/dom4j-1.3.ebuild b/dev-java/dom4j/dom4j-1.3.ebuild
index 5b54ca4d50fa..fcc9e876865d 100644
--- a/dev-java/dom4j/dom4j-1.3.ebuild
+++ b/dev-java/dom4j/dom4j-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/dom4j/dom4j-1.3.ebuild,v 1.1 2002/10/31 20:20:39 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/dom4j/dom4j-1.3.ebuild,v 1.2 2002/11/05 04:24:05 strider Exp $
S=${WORKDIR}/dom4j-${PV}
DESCRIPTION="dom4j is an easy to use, open source library for working with XML, XPath and XSLT on the Java platform using the Java Collections Framework and with full support for DOM, SAX and JAXP."
@@ -10,7 +10,7 @@ DEPEND=">=virtual/jdk-1.3"
REDEPND=">=virtual/jdk-1.3"
LICENSE="Apache-1.1"
SLOT="0"
-KEYWORDS="x86 ppc sparc sparc64 alpha"
+KEYWORDS="~X86"
IUSE=""
src_compile() {
@@ -22,7 +22,8 @@ src_install () {
cd ${WORKDIR}/dom4j-patched-${PV}
# If you need another jar change the name
# of the file in dojar to the one you need
- dojar build/dom4j.jar
+ mv build/dom4j.jar build/dom4j-${PV}.jar
+ dojar build/dom4j-${PV}.jar
dohtml -r build/doc/*
}
@@ -30,21 +31,20 @@ pkg_postinst() {
einfo "dom4j creates 3 jar files:"
einfo "------------------------------------------------------------------"
einfo "dom4j-full.jar: this contains all the dom4j code, the XPath engine
- and the interfaces for SAX and DOM. If in doubt use this JAR."
+ and the interfaces for SAX and DOM. If in doubt get this JAR."
einfo "dom4j.jar this contains all the dom4j code and the XPath engine but
- without the SAX or DOM interfaces. Usually the SAX and DOM
- interfaces come bundled with a JAXP parser so if you are using
- JAXP and crimson.jar or xerces.jar then dom4j.jar is the
- recommended JAR to use."
+ without the SAX or DOM interfaces. Usually the SAX and DOM
+ interfaces come bundled with a JAXP parser so if you are using
+ JAXP and crimson.jar or xerces.jar then dom4j.jar is the
+ recommended JAR to use."
einfo "dom4j-core.jar this contains all the dom4j code without the XPath
- engine and the SAX and DOM interfaces. This JAR is intended
- for developers who wish to keep the dom4j.jar and the jaxen.jar
- JARs seperate."
+ engine and the SAX and DOM interfaces. This JAR is intended
+ for developers who wish to keep the dom4j.jar and the jaxen.jar
+ JARs seperate."
einfo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>"
einfo "We are actually copying dom4j.jar. If you need another jar please
- feel free to modify the ebuild to fit your needs"
- einfo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>"
-
+ feel free to modify the ebuild to fit your needs"
+ einfo ">>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>"
}