summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-05-03 12:40:24 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-05-03 12:40:24 +0000
commit3345e91ce597d665ade95017ab14d18c4879ebdd (patch)
tree8717fae223c4c6e3cf0590ba796fba9320163f82 /dev-java/fastutil/fastutil-4.3.1-r1.ebuild
parentx86 stable wrt #176389 (diff)
downloadhistorical-3345e91ce597d665ade95017ab14d18c4879ebdd.tar.gz
historical-3345e91ce597d665ade95017ab14d18c4879ebdd.tar.bz2
historical-3345e91ce597d665ade95017ab14d18c4879ebdd.zip
Migrate fastutil-4.3.1, some QA fixes.
Package-Manager: portage-2.1.2.5
Diffstat (limited to 'dev-java/fastutil/fastutil-4.3.1-r1.ebuild')
-rw-r--r--dev-java/fastutil/fastutil-4.3.1-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/fastutil/fastutil-4.3.1-r1.ebuild b/dev-java/fastutil/fastutil-4.3.1-r1.ebuild
new file mode 100644
index 000000000000..667f97452dee
--- /dev/null
+++ b/dev-java/fastutil/fastutil-4.3.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-4.3.1-r1.ebuild,v 1.1 2007/05/03 12:40:24 nelchael Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Provides type-specific maps, sets and lists with a small memory footprint for much faster access and insertion."
+SRC_URI="http://fastutil.dsi.unimi.it/${P}-src.tar.gz"
+HOMEPAGE="http://fastutil.dsi.unimi.it"
+LICENSE="LGPL-2.1"
+SLOT="4.3"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+src_compile() {
+
+ emake sources || die "failed to make sources"
+
+ java-pkg-2_src_compile
+
+}
+
+src_install() {
+
+ java-pkg_newjar ${P}.jar
+
+ dodoc CHANGES README
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc java/it
+
+}