summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-06-27 09:49:03 +0000
committerVlastimil Babka <caster@gentoo.org>2007-06-27 09:49:03 +0000
commit9e01aa13688047aae2d02a77276cea500bcfc081 (patch)
tree62d15e3940f2224bf6cb49afb03ebf2e4cbea301 /dev-java/fastutil/fastutil-4.3.1-r1.ebuild
parentdev-util/mono-debugger: added patch that allows building against kernel >=2.6.19 (diff)
downloadhistorical-9e01aa13688047aae2d02a77276cea500bcfc081.tar.gz
historical-9e01aa13688047aae2d02a77276cea500bcfc081.tar.bz2
historical-9e01aa13688047aae2d02a77276cea500bcfc081.zip
Raise heap size for compiling also for other slots. Fixes bug #183356.
Package-Manager: portage-2.1.3_rc5
Diffstat (limited to 'dev-java/fastutil/fastutil-4.3.1-r1.ebuild')
-rw-r--r--dev-java/fastutil/fastutil-4.3.1-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-java/fastutil/fastutil-4.3.1-r1.ebuild b/dev-java/fastutil/fastutil-4.3.1-r1.ebuild
index 667f97452dee..0114d6ffb7aa 100644
--- a/dev-java/fastutil/fastutil-4.3.1-r1.ebuild
+++ b/dev-java/fastutil/fastutil-4.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-4.3.1-r1.ebuild,v 1.1 2007/05/03 12:40:24 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/fastutil/fastutil-4.3.1-r1.ebuild,v 1.2 2007/06/27 09:49:03 caster Exp $
JAVA_PKG_IUSE="doc source"
@@ -18,11 +18,11 @@ DEPEND=">=virtual/jdk-1.4"
RDEPEND=">=virtual/jre-1.4"
src_compile() {
-
emake sources || die "failed to make sources"
-
+ # bug 162650 and #175578 and #183356
+ java-pkg_init-compiler_
+ [[ ${GENTOO_COMPILER} != "javac" ]] && export ANT_OPTS="-Xmx512m"
java-pkg-2_src_compile
-
}
src_install() {