summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-26 05:28:37 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-26 05:28:37 +0000
commitea25464ffc0663b54cb8a6fe71fcfa83864d6e93 (patch)
tree25499f53d71ecd7219d7bc89c1176b959da6314d /dev-java/joda-time/joda-time-0.95.ebuild
parentnew license, joy (diff)
downloadhistorical-ea25464ffc0663b54cb8a6fe71fcfa83864d6e93.tar.gz
historical-ea25464ffc0663b54cb8a6fe71fcfa83864d6e93.tar.bz2
historical-ea25464ffc0663b54cb8a6fe71fcfa83864d6e93.zip
Initial Import. Closes #42533
Diffstat (limited to 'dev-java/joda-time/joda-time-0.95.ebuild')
-rw-r--r--dev-java/joda-time/joda-time-0.95.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-java/joda-time/joda-time-0.95.ebuild b/dev-java/joda-time/joda-time-0.95.ebuild
new file mode 100644
index 000000000000..d96358383cd9
--- /dev/null
+++ b/dev-java/joda-time/joda-time-0.95.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/joda-time/joda-time-0.95.ebuild,v 1.1 2004/02/26 05:28:36 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Joda-Time is an open-source project to provide a quality Java date and time API."
+HOMEPAGE="http://joda-time.sourceforge.net/"
+SRC_URI="mirror://sourceforge/joda-time/${PN}-${PV}-src.tar.gz"
+LICENSE="joda"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes"
+
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4"
+RDEPEND=">=virtual/jre-1.3"
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jike"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags}
+}
+
+src_install() {
+ java-pkg_dojar build/*.jar
+ use d7c && dohtml -r build/docs/
+}