summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2005-11-15 03:54:59 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2005-11-15 03:54:59 +0000
commitdf53e3d8e05a6a6e3251db016857e298130cbf39 (patch)
tree467954d7527f686325e1bd3d2c45488320038aa9 /dev-java/libgtk-java/libgtk-java-2.8.1.ebuild
parentFixing GCJ detect (diff)
downloadhistorical-df53e3d8e05a6a6e3251db016857e298130cbf39.tar.gz
historical-df53e3d8e05a6a6e3251db016857e298130cbf39.tar.bz2
historical-df53e3d8e05a6a6e3251db016857e298130cbf39.zip
Fixing GCJ detection
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-java/libgtk-java/libgtk-java-2.8.1.ebuild')
-rw-r--r--dev-java/libgtk-java/libgtk-java-2.8.1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-java/libgtk-java/libgtk-java-2.8.1.ebuild b/dev-java/libgtk-java/libgtk-java-2.8.1.ebuild
index 42d875c2403a..4bebb73389b7 100644
--- a/dev-java/libgtk-java/libgtk-java-2.8.1.ebuild
+++ b/dev-java/libgtk-java/libgtk-java-2.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgtk-java/libgtk-java-2.8.1.ebuild,v 1.2 2005/11/13 00:03:17 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgtk-java/libgtk-java-2.8.1.ebuild,v 1.3 2005/11/15 03:47:54 compnerd Exp $
# Must be before the gnome.org inherit
GNOME_TARBALL_SUFFIX="gz"
@@ -32,12 +32,14 @@ RDEPEND=">=virtual/jre-1.4
${DEPS}"
pkg_setup() {
- if use gcj -a ! built_with_use sys-devel/gcc gcj ; then
- ewarn
- ewarn "You must build gcc with the gcj support to build with gcj"
- ewarn
- ebeep 5
- die "No GCJ support found!"
+ if use gcj ; then
+ if ! built_with_use sys-devel/gcc gcj ; then
+ ewarn
+ ewarn "You must build gcc with the gcj support to build with gcj"
+ ewarn
+ ebeep 5
+ die "No GCJ support found!"
+ fi
fi
}