summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2007-05-01 06:19:56 +0000
committerAlistair Bush <ali_bush@gentoo.org>2007-05-01 06:19:56 +0000
commitecef61d73df8edbf43930bf9cd3d7b546467d0a9 (patch)
tree65a94a9d12d9d8f359bff8ac232ec494a4f1d713 /dev-java/xml-im-exporter/xml-im-exporter-1.1-r1.ebuild
parent*sigh* (diff)
downloadhistorical-ecef61d73df8edbf43930bf9cd3d7b546467d0a9.tar.gz
historical-ecef61d73df8edbf43930bf9cd3d7b546467d0a9.tar.bz2
historical-ecef61d73df8edbf43930bf9cd3d7b546467d0a9.zip
gen 2 java eclass migration revbump
Package-Manager: portage-2.1.2.5
Diffstat (limited to 'dev-java/xml-im-exporter/xml-im-exporter-1.1-r1.ebuild')
-rw-r--r--dev-java/xml-im-exporter/xml-im-exporter-1.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/xml-im-exporter/xml-im-exporter-1.1-r1.ebuild b/dev-java/xml-im-exporter/xml-im-exporter-1.1-r1.ebuild
new file mode 100644
index 000000000000..14a016807f81
--- /dev/null
+++ b/dev-java/xml-im-exporter/xml-im-exporter-1.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xml-im-exporter/xml-im-exporter-1.1-r1.ebuild,v 1.1 2007/05/01 06:19:56 ali_bush Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="XML Im-/Exporter is a low level library to assist you in the straight forward process of importing and exporting XML from and to your Java classes."
+HOMEPAGE="http://xml-im-exporter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}${PV}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${PN}"
+
+EANT_DOC_TARGET="javadocs"
+
+src_install() {
+ java-pkg_newjar "lib/${PN}${PV}.jar"
+
+ dodoc Changes.txt Open-Issues.txt Readme.txt Version.txt
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/main/*
+}