summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-12-20 20:20:29 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-12-20 20:20:29 +0000
commite8d7dd43820a4ce36cc6b6e597b7f3611ddd6ddb (patch)
treecced6b019f23df96fa0a575986b33e9d47b7a630 /dev-java/xmlgraphics-commons
parentx86 stable, bug #251643 (diff)
downloadhistorical-e8d7dd43820a4ce36cc6b6e597b7f3611ddd6ddb.tar.gz
historical-e8d7dd43820a4ce36cc6b6e597b7f3611ddd6ddb.tar.bz2
historical-e8d7dd43820a4ce36cc6b6e597b7f3611ddd6ddb.zip
Version bump. Fixes bug #202776. New slot because API changes prevent dev-java/fop from compiling against this.
Package-Manager: portage-2.1.6.1/cvs/Linux 2.6.27-gentoo-r5 i686
Diffstat (limited to 'dev-java/xmlgraphics-commons')
-rw-r--r--dev-java/xmlgraphics-commons/ChangeLog9
-rw-r--r--dev-java/xmlgraphics-commons/xmlgraphics-commons-1.3.1.ebuild77
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-java/xmlgraphics-commons/ChangeLog b/dev-java/xmlgraphics-commons/ChangeLog
index fa3019b5e5d0..17a4640f3ec9 100644
--- a/dev-java/xmlgraphics-commons/ChangeLog
+++ b/dev-java/xmlgraphics-commons/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/xmlgraphics-commons
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/ChangeLog,v 1.13 2008/03/10 13:10:01 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/ChangeLog,v 1.14 2008/12/20 20:20:29 betelgeuse Exp $
+
+*xmlgraphics-commons-1.3.1 (20 Dec 2008)
+
+ 20 Dec 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +xmlgraphics-commons-1.3.1.ebuild:
+ Version bump. Fixes bug #202776. New slot because API changes prevent
+ dev-java/fop from compiling against this.
10 Mar 2008; Petteri Räty <betelgeuse@gentoo.org>
xmlgraphics-commons-1.2.ebuild:
diff --git a/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.3.1.ebuild b/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.3.1.ebuild
new file mode 100644
index 000000000000..ac9a5d3ce5ce
--- /dev/null
+++ b/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.3.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.3.1.ebuild,v 1.1 2008/12/20 20:20:29 betelgeuse Exp $
+
+EAPI=1
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A library of several reusable components used by Apache Batik and Apache FOP."
+HOMEPAGE="http://xmlgraphics.apache.org/commons/index.html"
+SRC_URI="mirror://apache/xmlgraphics/commons/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="jpeg"
+
+# fails connect to X even tho it sets java.awt.headless
+RESTRICT="test"
+CDEPEND="dev-java/commons-io:1
+ >=dev-java/commons-logging-1:0"
+DEPEND="|| ( =virtual/jdk-1.6* =virtual/jdk-1.5* =virtual/jdk-1.4* )
+ test? (
+ dev-java/ant-junit
+ )
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.4
+ ${CDEPEND}"
+
+# TODO investigate producing .net libraries
+# stratigies for non sun jdk's/jre's
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+
+ if use jpeg && java-pkg_current-vm-matches kaffe; then
+ eerror "Sun-private JPEG support cannot be built with kaffe."
+ eerror "Please set your build VM to Sun, Blackdown, IBM or JRockit JDK."
+ eerror "See http://www.gentoo.org/doc/en/java.xml for details."
+ eerror "Alternatively, install this package with USE=-jpeg"
+ die "Cannot build with USE=jpeg and kaffe."
+ fi
+}
+
+JAVA_ANT_IGNORE_SYSTEM_CLASSES="true"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cd ${S}/lib || die
+ rm -v *.jar || die
+
+ java-pkg_jarfrom commons-io-1
+ java-pkg_jarfrom commons-logging
+}
+
+EANT_EXTRA_ARGS="-Djdk14.present=true"
+EANT_BUILD_TARGET="jar-main"
+EANT_DOC_TARGET="javadocs"
+
+src_compile() {
+ java-pkg-2_src_compile $(use jpeg && echo -Dsun.jpeg.present=true)
+}
+
+src_test() {
+ java-pkg_jarfrom --into lib junit
+ # probably needs ${af} from src_compile, doesn't work anyway
+ ANT_TASKS="ant-junit" eant -Djunit.present=true junit
+}
+
+src_install(){
+ java-pkg_newjar build/${P}.jar
+ use source && java-pkg_dosrc src/java/org src/java-1.4/org
+ use doc && java-pkg_dojavadoc build/javadocs
+}