summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-22 18:06:04 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-22 18:06:04 +0000
commitbc48f53eea1fdc1932a05093435bec6e322f1c45 (patch)
treea00ee8dad2957afc50a84fb61ccdd174513ad08a /dev-java
parent*** empty log message *** (diff)
downloadhistorical-bc48f53eea1fdc1932a05093435bec6e322f1c45.tar.gz
historical-bc48f53eea1fdc1932a05093435bec6e322f1c45.tar.bz2
historical-bc48f53eea1fdc1932a05093435bec6e322f1c45.zip
A xml parser for java
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jaxp/files/digest-jaxp-1.0.11
-rw-r--r--dev-java/jaxp/jaxp-1.0.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-java/jaxp/files/digest-jaxp-1.0.1 b/dev-java/jaxp/files/digest-jaxp-1.0.1
new file mode 100644
index 000000000000..48cdd0f86199
--- /dev/null
+++ b/dev-java/jaxp/files/digest-jaxp-1.0.1
@@ -0,0 +1 @@
+MD5 d4ecc7b13027f53161fecb7194c7b546 jaxp-1_0_1.zip
diff --git a/dev-java/jaxp/jaxp-1.0.1.ebuild b/dev-java/jaxp/jaxp-1.0.1.ebuild
new file mode 100644
index 000000000000..fa9abf68b941
--- /dev/null
+++ b/dev-java/jaxp/jaxp-1.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jaxp/jaxp-1.0.1.ebuild,v 1.1 2001/04/22 18:06:04 achim Exp $
+
+A=jaxp-1_0_1.zip
+S=${WORKDIR}/jaxp1.0.1
+DESCRIPTION="Java API for XML parsing"
+SRC_URI="ftp://${A}"
+HOMEPAGE="http://java.sun.com/products/jndi/"
+
+DEPEND=">=dev-lang/jdk-1.3.0
+ >=app-arch/unzip-5.41"
+RDEPEND=">=dev-lang/jdk-1.3.0"
+
+#Please download the sources from sun
+
+src_unpack() {
+ jar -xf ${DISTDIR}/${A}
+}
+
+src_compile() {
+ cd ${S}
+}
+
+src_install() {
+ cd ${S}
+ insinto /usr/lib/java
+ doins jaxp.jar parser.jar
+ dodoc LICENSE
+ docinto html
+ dodoc *.html
+ mv docs ${D}/usr/share/doc/${PF}/html/
+}
+
+
+