summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2006-02-16 07:54:30 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2006-02-16 07:54:30 +0000
commit552a232f8eb670f30dcce7751daaab977973dd96 (patch)
treec2d626c182c74570b91b40554c543f9634913bb9 /dev-lang/ghc
parentRename listed herd from dev-scheme to scheme; See Bug #94878. (diff)
downloadhistorical-552a232f8eb670f30dcce7751daaab977973dd96.tar.gz
historical-552a232f8eb670f30dcce7751daaab977973dd96.tar.bz2
historical-552a232f8eb670f30dcce7751daaab977973dd96.zip
Adding missing patches.
Package-Manager: portage-2.1_pre4-r1
Diffstat (limited to 'dev-lang/ghc')
-rw-r--r--dev-lang/ghc/Manifest12
-rw-r--r--dev-lang/ghc/files/ghc-6.4.1-configure.patch78
-rw-r--r--dev-lang/ghc/files/ghc-6.4.1-openal.patch29
3 files changed, 116 insertions, 3 deletions
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index ced870153749..ea85331643d4 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -25,6 +25,12 @@ SHA256 ed4c94ceb8e4749bd4d37a1542f5958175f0972b93a7137c5541698007b93d26 files/gh
MD5 ffd472c0685cf2766ce6533265f9a3c9 files/ghc-6.4-powerpc.patch 908
RMD160 007429fa9383eb214d3ee14dbb3ab6814788a3c9 files/ghc-6.4-powerpc.patch 908
SHA256 9406b0fa32d19bfbd55e6635070f3bdb57bd061a599924d940c8af8e34f36d3d files/ghc-6.4-powerpc.patch 908
+MD5 e522470e9d323932951f9efdb3fbf7e8 files/ghc-6.4.1-configure.patch 2666
+RMD160 26568ec35d05a3855ad8cf10593d15ccaedee847 files/ghc-6.4.1-configure.patch 2666
+SHA256 7519b2fa9a9faf4c3545ed471803f85bc102b2428eb9c53ea15ae457271d28b9 files/ghc-6.4.1-configure.patch 2666
+MD5 f55d9cead45de0979d9650dccde5e168 files/ghc-6.4.1-openal.patch 1270
+RMD160 fa7b57dc78cc36c9d74e55bc4873e6efc321f353 files/ghc-6.4.1-openal.patch 1270
+SHA256 fe6db1cf73571bca4af195321112985201e695cf67ed889cf626e5dc2b54b67e files/ghc-6.4.1-openal.patch 1270
MD5 af174f2e566a288f0e2276883a866827 files/ghc-updater 9075
RMD160 8fd05ff7a0bdc19b5d0041906de8c6f7e1b99a8f files/ghc-updater 9075
SHA256 3da2c1642c63c98e2b2fa8634496ad5e0a62404aaf4775c9a2eee6463c036216 files/ghc-updater 9075
@@ -43,7 +49,7 @@ SHA256 2b30834e4d9f141a1e1b63457d4af1f6a8cb6d4a47f8dd3b14e726277079769b metadata
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFD8+abdZ42PGEF17URAlilAKD2LHO7gjXtqA+0HjLEFJCDuxsFtACgu6FU
-PZftZof7i6D4ANx7DAlM9X0=
-=HJSC
+iD8DBQFD9C+3dZ42PGEF17URAvz/AKCUmfxB+2VQ01j3OcLZGvghjZcGrgCfZP09
+o1F0RWa0vTRfBqCNzg5hjU8=
+=lC0I
-----END PGP SIGNATURE-----
diff --git a/dev-lang/ghc/files/ghc-6.4.1-configure.patch b/dev-lang/ghc/files/ghc-6.4.1-configure.patch
new file mode 100644
index 000000000000..adacb6a70e4f
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.4.1-configure.patch
@@ -0,0 +1,78 @@
+diff -urwpN ghc-6.4.1/libraries/HGL/aclocal.m4 ghc-6.4.1.patched/libraries/HGL/aclocal.m4
+--- ghc-6.4.1/libraries/HGL/aclocal.m4 2004-11-23 08:35:13.000000000 -0400
++++ ghc-6.4.1.patched/libraries/HGL/aclocal.m4 2006-02-11 02:07:47.000000000 -0400
+@@ -1,2 +1,13 @@
+ # Empty file to avoid a dependency on automake: autoreconf calls aclocal to
+ # generate a temporary aclocal.m4t when no aclocal.m4 is present.
++
++# FP_ARG_HGL
++# -------------
++AC_DEFUN([FP_ARG_HGL],
++[AC_ARG_ENABLE([hgl],
++ [AC_HELP_STRING([--enable-hgl],
++ [build HGL.
++ (default=autodetect)])],
++ [enable_hgl=$enableval],
++ [enable_hgl=yes])
++])# FP_ARG_HGL
+diff -urwpN ghc-6.4.1/libraries/HGL/configure.ac ghc-6.4.1.patched/libraries/HGL/configure.ac
+--- ghc-6.4.1/libraries/HGL/configure.ac 2005-05-08 08:19:45.000000000 -0400
++++ ghc-6.4.1.patched/libraries/HGL/configure.ac 2006-02-11 02:07:47.000000000 -0400
+@@ -1,5 +1,10 @@
+ AC_INIT([Haskell Graphics Library], [3.1], [libraries@haskell.org], [HGL])
+
++FP_ARG_HGL
++
++if test "$enable_hgl" = no; then
++ HGL_BUILD_PACKAGE=no
++else
+ # Safety check: Ensure that we are in the correct source directory.
+ AC_CONFIG_SRCDIR([Graphics/HGL.hs])
+
+@@ -28,6 +33,7 @@ else
+ HGL_BUILD_PACKAGE=yes
+ PLATFORM=X11
+ fi
++fi
+ AC_SUBST([HGL_BUILD_PACKAGE])
+ AC_SUBST([PLATFORM])
+
+diff -urwpN ghc-6.4.1/libraries/X11/aclocal.m4 ghc-6.4.1.patched/libraries/X11/aclocal.m4
+--- ghc-6.4.1/libraries/X11/aclocal.m4 2004-11-23 08:35:18.000000000 -0400
++++ ghc-6.4.1.patched/libraries/X11/aclocal.m4 2006-02-11 02:07:38.000000000 -0400
+@@ -1,2 +1,13 @@
+ # Empty file to avoid a dependency on automake: autoreconf calls aclocal to
+ # generate a temporary aclocal.m4t when no aclocal.m4 is present.
++
++# FP_ARG_X11
++# -------------
++AC_DEFUN([FP_ARG_X11],
++[AC_ARG_ENABLE([x11],
++ [AC_HELP_STRING([--enable-x11],
++ [build a Haskell binding for X11.
++ (default=autodetect)])],
++ [enable_x11=$enableval],
++ [enable_x11=yes])
++])# FP_ARG_X11
+diff -urwpN ghc-6.4.1/libraries/X11/configure.ac ghc-6.4.1.patched/libraries/X11/configure.ac
+--- ghc-6.4.1/libraries/X11/configure.ac 2005-05-08 08:19:28.000000000 -0400
++++ ghc-6.4.1.patched/libraries/X11/configure.ac 2006-02-11 02:07:38.000000000 -0400
+@@ -1,5 +1,11 @@
+ AC_INIT([Haskell X11 package], [1.1], [libraries@haskell.org], [X11])
+
++FP_ARG_X11
++
++if test "$enable_x11" = no; then
++ X11_BUILD_PACKAGE=no
++ BUILD_PACKAGE_BOOL=False
++else
+ # Safety check: Ensure that we are in the correct source directory.
+ AC_CONFIG_SRCDIR([include/HsXlib.h])
+
+@@ -24,6 +30,7 @@ else
+ X11_BUILD_PACKAGE=yes
+ BUILD_PACKAGE_BOOL=True
+ fi
++fi
+ AC_SUBST([X11_BUILD_PACKAGE])
+ AC_SUBST([BUILD_PACKAGE_BOOL])
diff --git a/dev-lang/ghc/files/ghc-6.4.1-openal.patch b/dev-lang/ghc/files/ghc-6.4.1-openal.patch
new file mode 100644
index 000000000000..44a71d336ede
--- /dev/null
+++ b/dev-lang/ghc/files/ghc-6.4.1-openal.patch
@@ -0,0 +1,29 @@
+diff -urwpN ghc-6.4.1-orig/libraries/OpenAL/Sound/OpenAL/ALC/Context.hs ghc-6.4.1/libraries/OpenAL/Sound/OpenAL/ALC/Context.hs
+--- ghc-6.4.1-orig/libraries/OpenAL/Sound/OpenAL/ALC/Context.hs 2006-02-11 22:28:57.000000000 +0100
++++ ghc-6.4.1/libraries/OpenAL/Sound/OpenAL/ALC/Context.hs 2006-02-11 22:31:39.000000000 +0100
+@@ -66,10 +66,10 @@ foreign import CALLCONV unsafe "alcCreat
+ -- | Destroys the given context.
+
+ destroyContext :: Context -> IO ()
+-destroyContext = ignore . alcDestroyContext
++destroyContext = alcDestroyContext
+
+ foreign import CALLCONV unsafe "alcDestroyContext"
+- alcDestroyContext :: Context -> IO ALCenum
++ alcDestroyContext :: Context -> IO ()
+
+ --------------------------------------------------------------------------------
+
+@@ -102,10 +102,10 @@ foreign import CALLCONV unsafe "alcMakeC
+ -- | Performs processing on a synced context, nop on an asynchronous context.
+
+ processContext :: Context -> IO ()
+-processContext = ignore . alcProcessContext
++processContext = alcProcessContext
+
+ foreign import CALLCONV unsafe "alcProcessContext"
+- alcProcessContext :: Context -> IO Context
++ alcProcessContext :: Context -> IO ()
+
+ -- | Suspends processing on an asynchronous context. This is a legal nop on a
+ -- synced context.