summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-08 07:53:45 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-08 07:53:45 +0000
commita4e523e8f355c2e502cc7ab3e1370ddcd69b8bd7 (patch)
treef9ef1c9c5f40ade865049045806f9f78d1f12826 /dev-lang/ocaml/ocaml-3.08.ebuild
parentPrepare for ocaml-3.08 bump. (diff)
downloadhistorical-a4e523e8f355c2e502cc7ab3e1370ddcd69b8bd7.tar.gz
historical-a4e523e8f355c2e502cc7ab3e1370ddcd69b8bd7.tar.bz2
historical-a4e523e8f355c2e502cc7ab3e1370ddcd69b8bd7.zip
Version bump.
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.08.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.08.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-lang/ocaml/ocaml-3.08.ebuild b/dev-lang/ocaml/ocaml-3.08.ebuild
new file mode 100644
index 000000000000..b9831707c267
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.08.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.08.ebuild,v 1.1 2004/08/08 07:53:44 mattam Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
+HOMEPAGE="http://www.ocaml.org/"
+
+SRC_URI="http://caml.inria.fr/distrib/ocaml-3.08/${P}.0.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~alpha ~ia64 ~amd64 ~hppa ~macos"
+IUSE="tcltk"
+
+DEPEND="virtual/libc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+S="${WORKDIR}/${P}.0"
+
+src_compile() {
+ filter-flags "-fstack-protector"
+
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ # Fix for bug #23767.
+ if [ "${ARCH}" = "sparc" ]; then
+ myconf="${myconf} -host sparc-unknown-linux-gnu"
+ fi
+
+ # Fix for bug #46703
+ export LC_ALL=C
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}
+
+pkg_postinst() {
+ ranlib /usr/lib/ocaml/*.a
+
+ echo
+ einfo "OCaml is not binary compatible from version to version,"
+ einfo "so you (may) need to rebuild all packages depending on it that"
+ einfo "are actually installed on your system."
+ einfo "To do so, you can run: "
+ einfo "sh ${FILESDIR}/ocaml-rebuild.sh [-h | emerge options]"
+ einfo "Which will call emerge on all old packages with the given options"
+ echo
+}