summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-05-02 08:34:40 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-05-02 08:34:40 +0000
commit3be5b2168140974c0a4f5e6c7e3f774a5a17b6e9 (patch)
tree074af626bd7ce05dfeaef82e47f6ff5b509c5829 /dev-lang/ocaml
parentversion update, older versions seem to have developed problems (diff)
downloadhistorical-3be5b2168140974c0a4f5e6c7e3f774a5a17b6e9.tar.gz
historical-3be5b2168140974c0a4f5e6c7e3f774a5a17b6e9.tar.bz2
historical-3be5b2168140974c0a4f5e6c7e3f774a5a17b6e9.zip
fix for tk-8.4 issue
Diffstat (limited to 'dev-lang/ocaml')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/files/digest-ocaml-3.06-r11
-rw-r--r--dev-lang/ocaml/files/ocaml-3.06-tcltk-8.4compat-patch.bz2bin0 -> 639 bytes
-rw-r--r--dev-lang/ocaml/ocaml-3.06-r1.ebuild53
4 files changed, 59 insertions, 1 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index dd8715bf94e4..3cc3fea86aa8 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.10 2003/04/11 18:32:16 method Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.11 2003/05/02 08:34:39 george Exp $
+
+ 01 May 2003; George Shapovalov <george@gentoo.org> ocaml-3.06-r1.ebuild :
+ updated the ebuild to incorporate the fix for tk-8.4 necessary for lablgl.
+ Thanks to Rick Harris <rickharris@mightylegends.zapto.org> for the note and the patch.
*ocaml-3.06 (28 Jan 2003)
diff --git a/dev-lang/ocaml/files/digest-ocaml-3.06-r1 b/dev-lang/ocaml/files/digest-ocaml-3.06-r1
new file mode 100644
index 000000000000..9f9f472447f2
--- /dev/null
+++ b/dev-lang/ocaml/files/digest-ocaml-3.06-r1
@@ -0,0 +1 @@
+MD5 51530ed183b511ce19fed325c8ab1b43 ocaml-3.06.tar.gz 2436887
diff --git a/dev-lang/ocaml/files/ocaml-3.06-tcltk-8.4compat-patch.bz2 b/dev-lang/ocaml/files/ocaml-3.06-tcltk-8.4compat-patch.bz2
new file mode 100644
index 000000000000..a51778cb01ca
--- /dev/null
+++ b/dev-lang/ocaml/files/ocaml-3.06-tcltk-8.4compat-patch.bz2
Binary files differ
diff --git a/dev-lang/ocaml/ocaml-3.06-r1.ebuild b/dev-lang/ocaml/ocaml-3.06-r1.ebuild
new file mode 100644
index 000000000000..3edeea5b0b45
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.06-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06-r1.ebuild,v 1.1 2003/05/02 08:34:40 george Exp $
+
+IUSE="tcltk"
+
+inherit flag-o-matic
+filter-flags "-fstack-protector"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
+SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
+HOMEPAGE="http://www.ocaml.org/"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+
+SLOT="0"
+LICENSE="QPL-1.0 LGPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+src_compile()
+{
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ epatch ${FILESDIR}/ocaml-3.06-tcltk-8.4compat-patch.bz2
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install ()
+{
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}