summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-03-19 14:48:58 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-03-19 14:48:58 +0000
commit72f0bc6bd72fd0af750e3483c0912ca54dc662e2 (patch)
tree972f403775e86fcd2099763280c18c6b70ae3c32 /dev-lang/sather
parentAdded net-mail/dot-forward to RDEPEND (diff)
downloadhistorical-72f0bc6bd72fd0af750e3483c0912ca54dc662e2.tar.gz
historical-72f0bc6bd72fd0af750e3483c0912ca54dc662e2.tar.bz2
historical-72f0bc6bd72fd0af750e3483c0912ca54dc662e2.zip
Initial releases of these packages.
Diffstat (limited to 'dev-lang/sather')
-rw-r--r--dev-lang/sather/ChangeLog10
-rw-r--r--dev-lang/sather/files/digest-sather-1.37
-rw-r--r--dev-lang/sather/sather-1.3.ebuild69
3 files changed, 86 insertions, 0 deletions
diff --git a/dev-lang/sather/ChangeLog b/dev-lang/sather/ChangeLog
new file mode 100644
index 000000000000..efa90a5915d6
--- /dev/null
+++ b/dev-lang/sather/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lang/sather
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/sather/ChangeLog,v 1.1 2002/03/19 14:48:58 gbevin Exp $
+
+*sather-1.3 (19 Mar 2002)
+
+ 19 Mar 2002; G.Bevin <gbevin@gentoo.org> sather-1.3.ebuild
+ files/sather-1.3:
+
+ Initial package for the sather language.
diff --git a/dev-lang/sather/files/digest-sather-1.3 b/dev-lang/sather/files/digest-sather-1.3
new file mode 100644
index 000000000000..c45a20bf4c2a
--- /dev/null
+++ b/dev-lang/sather/files/digest-sather-1.3
@@ -0,0 +1,7 @@
+MD5 62316a76982d356b62a474b41bda4f9f Descript.ps.gz 405546
+MD5 38070dd26b17a283851d061817c9ab83 Sather-1.3.tar.gz 8444295
+MD5 a1ac828600d76e1a6ae7752906af19a7 sather-specification-000328.html.tar.gz 65633
+MD5 5cb2db3a756376e21f37b0471b74ee81 sather-specification-000328.ps.gz 107425
+MD5 7d6406c0ef5e41c8e8093459b8b5615f sather-tutorial-000328.html.tar.gz 255712
+MD5 6bafe799e7f556166935d3d0a2f1ea82 sather-tutorial-000328.ps.gz 257895
+MD5 ff8fcc87a3d7d8b4ec725885124e6e9a satish-thatte.ps.gz 30137
diff --git a/dev-lang/sather/sather-1.3.ebuild b/dev-lang/sather/sather-1.3.ebuild
new file mode 100644
index 000000000000..57f6d92cb504
--- /dev/null
+++ b/dev-lang/sather/sather-1.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Geert Bevin <gbevin@uwyn.com>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/sather/sather-1.3.ebuild,v 1.1 2002/03/19 14:48:58 gbevin Exp $
+
+S="${WORKDIR}/Sather-1.3"
+DESCRIPTION="Sather is an object oriented language designed to be simple, efficient, safe, flexible and non-proprietary."
+SRC_URI="http://www.cs.waikato.ac.nz/sather/release/downloads/Sather-1.3.tar.gz
+ ftp://ftp.gnu.org/gnu/sather/Doc/sather-tutorial-000328.ps.gz
+ ftp://ftp.gnu.org/gnu/sather/Doc/sather-tutorial-000328.html.tar.gz
+ ftp://ftp.gnu.org/gnu/sather/Doc/sather-specification-000328.html.tar.gz
+ ftp://ftp.gnu.org/gnu/sather/Doc/sather-specification-000328.ps.gz
+ http://www.icsi.berkeley.edu/~sather/Publications/satish-thatte.ps.gz
+ http://www.icsi.berkeley.edu/~sather/Documentation/LanguageDescription/Descript.ps.gz"
+HOMEPAGE="http://www.cs.waikato.ac.nz/sather/ http://www.icsi.berkeley.edu/~sather/"
+
+DEPEND=">=sys-devel/gcc-2.95.3-r5
+ >=dev-libs/boehm-gc-6.0"
+RDEPEND=">=sys-devel/gcc-2.95.3-r5"
+
+src_unpack() {
+ unpack Sather-1.3.tar.gz
+
+ mkdir doc
+ cd doc
+ unpack sather-tutorial-000328.html.tar.gz
+ unpack sather-specification-000328.html.tar.gz
+ cp ${DISTDIR}/sather-tutorial-000328.ps.gz .
+ cp ${DISTDIR}/sather-specification-000328.ps.gz .
+ cp ${DISTDIR}/satish-thatte.ps.gz .
+ cp ${DISTDIR}/Descript.ps.gz .
+}
+
+src_compile() {
+
+ export SATHER_HOME="$S"
+ export LOCALE="en_NZ"
+ export SATHER_ENV="$SATHER_HOME/resources/$LOCALE/bin/LIBCHARS-posix"
+ export SATHER_RESOURCES="$SATHER_HOME/resources/$LOCALE"
+ export PATH="$PATH:$SATHER_HOME/bin"
+
+ ./configure linux || die
+ make || die
+
+}
+
+src_install () {
+
+ dodir /usr
+ cp -a ${WORKDIR}/Sather-1.3 ${D}/usr/sather
+ rm -rf ${D}/usr/sather/bin/sacomp.code
+ rm -rf ${D}/usr/sather/bin/sacomp-boot.code
+ rm -rf ${D}/usr/sather/system
+
+ cd ${WORKDIR}
+ dodoc doc/sather-specification-000328.ps.gz doc/sather-tutorial-000328.ps.gz doc/satish-thatte.ps.gz doc/Descript.ps.gz
+ cp -a doc/specification.html ${D}/usr/share/doc/${P}
+ cp -a doc/tutorial.html ${D}/usr/share/doc/${P}
+
+ dodir /etc/env.d
+cat >> ${D}/etc/env.d/05sather <<EOF
+ export SATHER_HOME="/usr/sather"
+ export LOCALE="en_NZ"
+ export SATHER_ENV="/usr/sather/resources/en_NZ/bin/LIBCHARS-posix"
+ export SATHER_RESOURCES="/usr/sather/resources/en_NZ"
+ export PATH="/usr/sather/bin"
+EOF
+
+}