summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2013-08-08 20:50:00 +0000
committerIan Stakenvicius <axs@gentoo.org>2013-08-08 20:50:00 +0000
commitf893124b99a64237398de64ae549022a3725dad4 (patch)
tree7dd0487e5eaf17ccdca909085ce4f43ed631509f /dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild
parentFix dep for perl 5.16 (bug 479074) (diff)
downloadhistorical-f893124b99a64237398de64ae549022a3725dad4.tar.gz
historical-f893124b99a64237398de64ae549022a3725dad4.tar.bz2
historical-f893124b99a64237398de64ae549022a3725dad4.zip
Slotted spidermonkey-17, all newer versions of spidermonkey will now be slotted; converted most ebuilds to python-any-r1; dropped old versions of 1.8.5 and 1.8.7
Package-Manager: portage-2.1.12.2/cvs/Linux x86_64 Manifest-Sign-Key: 0x2B6559ED
Diffstat (limited to 'dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild')
-rw-r--r--dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild b/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild
index a0c145b4c092..da33fb226c4e 100644
--- a/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild
+++ b/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild,v 1.18 2013/06/08 21:35:23 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/spidermonkey/spidermonkey-1.8.5-r4.ebuild,v 1.19 2013/08/08 20:49:55 axs Exp $
EAPI="5"
WANT_AUTOCONF="2.1"
-inherit autotools eutils toolchain-funcs multilib python versionator pax-utils
+PYTHON_COMPAT=( python2_{6,7} )
+PYTHON_REQ_USE="threads"
+inherit autotools eutils toolchain-funcs multilib python-any-r1 versionator pax-utils
MY_PN="js"
TARBALL_PV="$(replace_all_version_separators '' $(get_version_component_range 1-3))"
@@ -24,14 +26,12 @@ BUILDDIR="${S}/js/src"
RDEPEND=">=dev-libs/nspr-4.7.0"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
app-arch/zip
- =dev-lang/python-2*[threads]
virtual/pkgconfig"
pkg_setup(){
if [[ ${MERGE_TYPE} != "binary" ]]; then
- python_set_active_version 2
- python_pkg_setup
export LC_ALL="C"
fi
}
@@ -67,7 +67,7 @@ src_configure() {
CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
- LD="$(tc-getLD)" PYTHON="$(PYTHON)" \
+ LD="$(tc-getLD)" \
econf \
${myopts} \
--enable-jemalloc \