summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-30 22:26:07 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-30 22:26:07 +0000
commit3a4ff98d9dc369d73ee24ed439be41f3eaaaa516 (patch)
treecd02813913250a3eec1d4c2a68bc45f076335f84 /dev-lang/squeak/squeak-3.4.1-r1.ebuild
parentAdded patch to fix gcc-3.3.x multi-line string issues. Closes Bug #32122. (diff)
downloadhistorical-3a4ff98d9dc369d73ee24ed439be41f3eaaaa516.tar.gz
historical-3a4ff98d9dc369d73ee24ed439be41f3eaaaa516.tar.bz2
historical-3a4ff98d9dc369d73ee24ed439be41f3eaaaa516.zip
Added patch to fix gcc-3.3.x multi-line string issues. Closes Bug #32122.
Diffstat (limited to 'dev-lang/squeak/squeak-3.4.1-r1.ebuild')
-rw-r--r--dev-lang/squeak/squeak-3.4.1-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-lang/squeak/squeak-3.4.1-r1.ebuild b/dev-lang/squeak/squeak-3.4.1-r1.ebuild
index 9ed818248ae1..8533ef82d5f9 100644
--- a/dev-lang/squeak/squeak-3.4.1-r1.ebuild
+++ b/dev-lang/squeak/squeak-3.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.4.1-r1.ebuild,v 1.1 2003/10/11 09:32:56 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.4.1-r1.ebuild,v 1.2 2003/10/30 22:26:04 kumba Exp $
inherit libtool flag-o-matic eutils
strip-flags
@@ -29,6 +29,13 @@ RDEPEND="dev-lang/squeak-vm
S="${WORKDIR}/Squeak-${NV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc33-string-fix.patch
+}
+
src_compile() {
local myconf=""