summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-09-25 07:01:23 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-09-25 07:01:23 +0000
commit5ed8a433519b107e9fc9e68e8e8e205b39c845ca (patch)
tree6b3068a929627b0183d69710f191f9d60b9cb104 /dev-lang/tinycobol/tinycobol-0.61.ebuild
parentVersion bump (diff)
downloadhistorical-5ed8a433519b107e9fc9e68e8e8e205b39c845ca.tar.gz
historical-5ed8a433519b107e9fc9e68e8e8e205b39c845ca.tar.bz2
historical-5ed8a433519b107e9fc9e68e8e8e205b39c845ca.zip
Version bump
Diffstat (limited to 'dev-lang/tinycobol/tinycobol-0.61.ebuild')
-rw-r--r--dev-lang/tinycobol/tinycobol-0.61.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-lang/tinycobol/tinycobol-0.61.ebuild b/dev-lang/tinycobol/tinycobol-0.61.ebuild
new file mode 100644
index 000000000000..1c319e8a8cd8
--- /dev/null
+++ b/dev-lang/tinycobol/tinycobol-0.61.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.61.ebuild,v 1.1 2003/09/25 07:01:15 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="COBOL for linux"
+HOMEPAGE="http://tiny-cobol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tiny-cobol/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-2.0
+ sys-libs/db"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ econf || die
+ make || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/man/man1
+ dodir /usr/lib
+ dodir /usr/share/htcobol
+ einstall
+ dodoc AUTHORS ChangeLog README STATUS
+}