summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-12 22:37:26 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-12 22:37:26 +0000
commitb86f92666b2f292ae52b3c6e87a6da121f0fdaf2 (patch)
tree2495461b026b71e29dfdcd471f95d6a71ca24064 /dev-lang
parentadd back in src_compile since it isnt 100% #33258 (diff)
downloadhistorical-b86f92666b2f292ae52b3c6e87a6da121f0fdaf2.tar.gz
historical-b86f92666b2f292ae52b3c6e87a6da121f0fdaf2.tar.bz2
historical-b86f92666b2f292ae52b3c6e87a6da121f0fdaf2.zip
DEPEND/coreutils fixes #33021
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/cm3/cm3-5.2.6.ebuild27
1 files changed, 25 insertions, 2 deletions
diff --git a/dev-lang/cm3/cm3-5.2.6.ebuild b/dev-lang/cm3/cm3-5.2.6.ebuild
index 718007fee17e..7b5fcc0841f3 100644
--- a/dev-lang/cm3/cm3-5.2.6.ebuild
+++ b/dev-lang/cm3/cm3-5.2.6.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3/cm3-5.2.6.ebuild,v 1.4 2003/07/18 18:59:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3/cm3-5.2.6.ebuild,v 1.5 2003/11/12 22:37:26 vapier Exp $
+
+inherit fixheadtails
DESCRIPTION="Critical Mass Modula-3 compiler"
HOMEPAGE="http://www.elegosoft.com/cm3/"
@@ -11,7 +13,8 @@ SLOT="0"
KEYWORDS="x86 ppc"
IUSE="tcltk"
-DEPEND="tcltk? ( dev-lang/tcl )
+RDEPEND="tcltk? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
sys-devel/gcc
dev-lang/cm3-bin"
@@ -25,6 +28,26 @@ unset M3GC_SIMPLE
&& HAVE_TCL="yes" \
|| HAVE_TCL="no"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ ht_fix_file \
+ m3-comm/rdwr/test/john/src/Main.m3 \
+ m3-demo/mentor/src/unionfind/junoLogs/reorder \
+ m3-sys/m3cc/gcc/config.guess--cfl \
+ m3-sys/m3cc/gcc/configure \
+ m3-sys/m3cc/gcc/configure--cfl \
+ m3-sys/m3cc/gcc/contrib/test_summary \
+ m3-sys/m3cc/gcc/gcc/configure \
+ m3-sys/m3cc/gcc/gcc/configure--cfl \
+ m3-sys/m3cc/gcc/gcc/configure.in \
+ m3-sys/m3cc/gcc/ltcf-c.sh \
+ m3-sys/m3cc/gcc/ltcf-gcj.sh \
+ m3-sys/m3gdb/gdb/configure \
+ m3-sys/m3tests/src/m3makefile \
+ scripts/pkginfo.sh
+}
+
src_compile() {
cd scripts
for s in do-cm3-core do-cm3-base ; do