summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-06 10:01:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-06 10:01:47 +0000
commit137f1e7f70bf1799a36ff048e86b4437efffd1bd (patch)
tree088826241b2603465853801a19511d79774f9411 /dev-libs/DirectFB
parentUpdated to version 0.3.26. Closes BUG #3173. (diff)
downloadhistorical-137f1e7f70bf1799a36ff048e86b4437efffd1bd.tar.gz
historical-137f1e7f70bf1799a36ff048e86b4437efffd1bd.tar.bz2
historical-137f1e7f70bf1799a36ff048e86b4437efffd1bd.zip
version bump
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/ChangeLog9
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.11.ebuild (renamed from dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild)24
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.9-r1.ebuild100
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.111
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.9-r11
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.9-r21
6 files changed, 19 insertions, 117 deletions
diff --git a/dev-libs/DirectFB/ChangeLog b/dev-libs/DirectFB/ChangeLog
index a0843002d7e4..2ecf5dff6cf9 100644
--- a/dev-libs/DirectFB/ChangeLog
+++ b/dev-libs/DirectFB/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/DirectFB
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.9 2002/05/26 14:05:33 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/ChangeLog,v 1.10 2002/06/06 10:01:47 seemant Exp $
+
+*DirectFB-0.9.11 (6 Jun 2002)
+
+ 6 Jun 2002; Seemant Kulleen <seemant@gentoo.org> DirectFB-0.9.11.ebuild
+ files/digest-DirectFB-0.9.11 :
+
+ Version bump.
*DirectFB-0.9.10-r1 (26 Apr 2002)
diff --git a/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild b/dev-libs/DirectFB/DirectFB-0.9.11.ebuild
index d65aabd23fe5..c281d4e45960 100644
--- a/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild
+++ b/dev-libs/DirectFB/DirectFB-0.9.11.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: system@gentoo.org
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.9-r2.ebuild,v 1.6 2002/05/23 06:50:10 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.11.ebuild,v 1.1 2002/06/06 10:01:47 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="DirectFB is a thin library on top of the Linux framebuffer devices"
@@ -16,26 +16,23 @@ DEPEND="sys-devel/perl
flash? ( >=media-libs/libflash-0.4.10 )
truetype? ( >=media-libs/freetype-2.0.1 )
quicktime? ( media-libs/quicktime4linux )"
-# avi? ( =media-video/avifile-0.6* )
+# avi? ( >=media-video/avifile-0.7.4.20020426-r2 )"
-RDEPEND="${DEPEND}"
src_compile() {
- local myconf
+ local myconf=""
- use mmx \
- && myconf="${myconf} --enable-mmx" \
- || myconf="${myconf} --disable-mmx"
+ # Bug in the ./configure script that breaks if you
+ # have --enable-mmx
+ use mmx || myconf="${myconf} --disable-mmx"
-# avifile that is in portage currently does not work with directfb
-# an older one in the 0.6.0 series is required.
+# Still do not work currently
# use avi \
# && myconf="${myconf} --enable-avifile" \
# || myconf="${myconf} --disable-avifile"
-
myconf="${myconf} --disable-avifile"
-
+
use mpeg \
&& myconf="${myconf} --with-libmpeg3=/usr/include/libmpeg3" \
|| myconf="${myconf} --disable-libmpeg3"
@@ -56,9 +53,7 @@ src_compile() {
&& myconf="${myconf} --enable-freetype" \
|| myconf="${myconf} --disable-freetype"
- ./configure \
- --prefix=/usr \
- ${myconf} || die
+ econf ${myconf} || die
use mpeg && ( \
cd ${S}/interfaces/IDirectFBVideoProvider
@@ -82,3 +77,4 @@ src_install () {
dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
dohtml -r docs/html
}
+
diff --git a/dev-libs/DirectFB/DirectFB-0.9.9-r1.ebuild b/dev-libs/DirectFB/DirectFB-0.9.9-r1.ebuild
deleted file mode 100644
index 756e093ffc06..000000000000
--- a/dev-libs/DirectFB/DirectFB-0.9.9-r1.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: system@gentoo.org
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.9-r1.ebuild,v 1.2 2002/04/16 03:15:43 seemant Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="DirectFB is a thin library on top of the Linux framebuffer devices"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-HOMEPAGE="http://www.directfb.org"
-
-DEPEND="sys-devel/perl
- avi? ( =media-video/avifile-0.6* )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- flash? ( >=media-libs/libflash-0.4.10 )
- libmpeg3? ( >=media-libs/libmpeg3-1.2.3 )
- truetype? ( >=media-libs/freetype-2.0.1 )
- quicktime? ( media-libs/quicktime4linux )"
-
-RDEPEND="${DEPEND}"
-
-extralibinfo=""
-use libmpeg3 && extralibinfo="LIBMPEG3_DIR=/usr/lib LIBMPEG3_LIBS=-lmpeg3"
-
-src_unpack() {
-
- unpack ${A}
-
- use libmpeg3 \
- && cp /usr/lib/libmpeg3.a ${S}/interfaces/IDirectFBVideoProvider/no
-}
-
-src_compile() {
-
-
- use mmx \
- && myconf="${myconf} --enable-mmx" \
- || myconf="${myconf} --disable-mmx"
-
-# avifile that is in portage currently does not work with directfb
-# an older one in the 0.6.0 series is required.
-# use avi \
-# && myconf="${myconf} --enable-avifile" \
-# || myconf="${myconf} --disable-avifile"
-
- myconf="${myconf} --disable-avifile"
-
- use libmpeg3 \
- && myconf="${myconf} --with-libmpeg3=/usr/include/libmpeg3" \
- && mkdir ${S}/interfaces/IDirectFBVideoProvider/no \
- || myconf="${myconf} --without-libmpeg3"
-
-# use libmpeg3 \
-# && myconf="${myconf} --with-libmpeg3=/usr/include/libmpeg3" \
-# || myconf="${myconf} --without-libmpeg3"
-
- use jpeg \
- && myconf="${myconf} --enable-jpeg" \
- || myconf="${myconf} --disable-jpeg"
-
- use png \
- && myconf="${myconf} --enable-png" \
- || myconf="${myconf} --disable-png"
-
- use gif \
- && myconf="${myconf} --enable-gif" \
- || myconf="${myconf} --disable-gif"
-
- use truetype \
- && myconf="${myconf} --enable-freetype" \
- || myconf="${myconf} --disable-freetype"
-
- if [ "$DEBUG" ] ; then
- myconf="${myconf} --enable-debug"
- else
- myconf="${myconf} --disable-debug"
- fi
-
- ./configure \
- --prefix=/usr \
- ${myconf} || die
-
- make \
- "${extralibinfo}" || die
-
-}
-
-src_install () {
-
- insinto /etc
- doins fb.modes
-
- make \
- DESTDIR=${D} \
- install || die
-
- dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
- dohtml -r docs/html
-}
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.11 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.11
new file mode 100644
index 000000000000..42d20eba59ad
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-0.9.11
@@ -0,0 +1 @@
+MD5 f0d6ceb41d83fc75eed59af9915c072d DirectFB-0.9.11.tar.gz 696979
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.9-r1 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.9-r1
deleted file mode 100644
index e7ac2bbe0cbf..000000000000
--- a/dev-libs/DirectFB/files/digest-DirectFB-0.9.9-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 46cff64fa95e927bdbce38fc37f5baf6 DirectFB-0.9.9.tar.gz 594770
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.9-r2 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.9-r2
deleted file mode 100644
index e7ac2bbe0cbf..000000000000
--- a/dev-libs/DirectFB/files/digest-DirectFB-0.9.9-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 46cff64fa95e927bdbce38fc37f5baf6 DirectFB-0.9.9.tar.gz 594770