summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-02 16:46:35 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-02 16:46:35 +0000
commitc6b8da051e92f40604f2e41e2a6e2931a801b4f2 (patch)
treeced059dfb26c1ca0203fb80b2ea0539daecdc310 /dev-libs/DirectFB
parentprefix fix (diff)
downloadhistorical-c6b8da051e92f40604f2e41e2a6e2931a801b4f2.tar.gz
historical-c6b8da051e92f40604f2e41e2a6e2931a801b4f2.tar.bz2
historical-c6b8da051e92f40604f2e41e2a6e2931a801b4f2.zip
*** empty log message ***
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.0.ebuild30
-rw-r--r--dev-libs/DirectFB/files/digest-DirectFB-0.9.01
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.0.ebuild b/dev-libs/DirectFB/DirectFB-0.9.0.ebuild
new file mode 100644
index 000000000000..9a9a47e7a1a9
--- /dev/null
+++ b/dev-libs/DirectFB/DirectFB-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.0.ebuild,v 1.1 2001/05/02 16:46:35 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="DirectFB is a thin library on top of the Linux fb devices"
+SRC_URI="http://www.directfb.org/download/${A}"
+HOMEPAGE="http://www.directfb.org"
+
+DEPEND="virtual/glibc >=media-libs/freetype-2.0.1"
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST}
+ cp Makefile Makefile.orig
+ sed -e "s:examples::" Makefile.orig > Makefile
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ dodoc AUTHORS COPYING ChangeLog NEWS README* TODO
+ docinto html
+ dodoc docs/html/*.{png,html}
+}
+
diff --git a/dev-libs/DirectFB/files/digest-DirectFB-0.9.0 b/dev-libs/DirectFB/files/digest-DirectFB-0.9.0
new file mode 100644
index 000000000000..b6b2d8b4b84d
--- /dev/null
+++ b/dev-libs/DirectFB/files/digest-DirectFB-0.9.0
@@ -0,0 +1 @@
+MD5 e4f375955ae6b70a79cbf706af780c35 DirectFB-0.9.0.tar.gz